Bug 486802 - Get web-whois for .tg working again
Get web-whois for .tg working again
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jwhois (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 00:25 EST by Robert Scheck
Modified: 2009-02-27 05:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 05:17:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-02-22 00:25:16 EST
Description of problem:
The current web-whois for .tg doesn't work (whois nic.tg), just many errors
and stuff, because the wrong page is used. I tried to get something working,
but I'm failing at a point. Maybe you've got an idea, what I'm doing wrong?

Version-Release number of selected component (if applicable):
jwhois-4.0-10

How reproducible:
Everytime, whois query fails.

Actual and expected results:
Currently we have:

--- snipp ---
"www\\.nic\\.tg" {
        http = "true";
        http-method = "GET";
        http-action = "/moteur/info_dom.php";
        form-element = "domaine";
}
--- snapp ---

Following works for me, but queries ALWAYS for nic.tg and I'm unable to get
some variable into...the request has to be POST otherwise it won't work, and
the .tg is a separate field, so the tosearch needs to be just the domain name
without the top level domain.

--- snipp ---
"www\\.nic\\.tg" {
        http = "true";
        http-method = "POST";
        http-action = "/nictg/indexplus.php?pg=verifdom&op=whois";
        form-element = "Submit";
        form-extra = "tosearch=nic&typedom=.tg"; # All but last domain segment
}
--- snapp ---

Any ideas? I tried to replace "nic" by "${+2}", but that doesn't work somehow
in form-extra as it seems...

Additional info:
Please try to get this fix upstream - upstream is unluckily always very very
unresponsive to me.
Comment 1 Robert Scheck 2009-02-22 12:19:50 EST
Okay, I found my mistake. The new block is the following...please use it.

--- snipp ---
"www\\.nic\\.tg" {
        http = "true";
        http-method = "POST";
        http-action = "/nictg/indexplus.php?pg=verifdom&op=whois";
        query-format = "tosearch=${+2}&typedom=.tg";
}
--- snapp ---

Now "whois nic.tg" and "whois cafe.tg" are e.g. working examples...

Note You need to log in before you can comment on or make changes to this bug.