Bug 486823 - Update whois server of .ai (match IANA, real whois server is better than web-whois)
Update whois server of .ai (match IANA, real whois server is better than web-...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jwhois (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 07:47 EST by Robert Scheck
Modified: 2009-02-27 05:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 05:21:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-02-22 07:47:37 EST
Description of problem:
According to IANA (http://www.iana.org/domains/root/db/ia.html), the current
authoritative whois server is "whois.ai", /etc/jwhois.conf contains something 
else which looks like a web-whois, please change. Real whois server is always
better than something via http.

Version-Release number of selected component (if applicable):
jwhois-4.0-10

How reproducible:
Everytime.
  
Actual results:
# whois nic.ai
[Querying http://whois.offshore.ai/cgi-bin/whois.pl]
[...]
# 

Expected results:
Replace: "\\.ai$" = "whois.offshore.ai";
by     : "\\.ai$" = "whois.ai";

AND REMOVE the following block:

--- snipp ---
        "whois\\.offshore\\.ai" {
                http = "true";
                http-method = "POST";
                http-action = "/cgi-bin/whois.pl";
                form-element = "domain-name";
        }
--- snapp ---

Additional info:
Please try to get this fix upstream - upstream is unluckily always very very
unresponsive to me.

Note You need to log in before you can comment on or make changes to this bug.