Bug 486841 - Xlib: extension "XFree86-Misc" missing on display
Xlib: extension "XFree86-Misc" missing on display
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 08:49 EST by sangu
Modified: 2009-02-26 10:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 10:11:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2009-02-22 08:49:47 EST
Description of problem:
Whenever gnome-screensaver activates, 
< Xlib:  extension "XFree86-Misc" missing on display ":0.0" > in .xessession-errors

$ cat ~/.xsession-errors
<skip>
** (gnome-screensaver:7730): WARNING **: Unable to find watch for alarm
Xlib:  extension "XFree86-Misc" missing on display ":0.0".

Version-Release number of selected component (if applicable):
1.5.99.903-3.fc11

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
$ cat /var/log/Xorg.0.log | grep extension
(**) ModulePath set to "/usr/lib64/xorg/modules/extensions/nvidia,/usr/lib64/xorg/modules"
(II) Loading /usr/lib64/xorg/modules/extensions//libextmod.so
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) Loading /usr/lib64/xorg/modules/extensions//libdbe.so
(II) Loading extension DOUBLE-BUFFER
(II) Loading /usr/lib64/xorg/modules/extensions/nvidia//libglx.so
(II) Loading extension GLX
(II) Loading /usr/lib64/xorg/modules/extensions//librecord.so
(II) Loading extension RECORD
(II) Loading /usr/lib64/xorg/modules/extensions//libdri.so
(II) Loading extension XFree86-DRI
(II) Loading /usr/lib64/xorg/modules/extensions//libdri2.so
(II) Loading extension DRI2
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Loading extension NV-GLX
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
Comment 1 Matěj Cepl 2009-02-25 10:37:55 EST
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat mailing lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo
Comment 2 sangu 2009-02-26 08:46:20 EST
hmm, this problem seems to be not related to Nvidia binary driver.

$ cat /var/log/Xorg.0.log | grep Misc

$ cat /var/log/Xorg.4.log.old | grep Misc (X.Org X Server 1.5.3 log)
(II) Loading extension XFree86-Misc
Comment 3 sangu 2009-02-26 08:58:30 EST
gnome-screensaver needs to XFree86-Misc, maybe.

http://kojipkgs.fedoraproject.org/packages/gnome-screensaver/2.25.2/5.fc11/data/logs/i586/build.log
[...]
checking for XF86MiscSetGrabKeysState in -lXxf86misc... yes
[...]
Comment 4 Adam Jackson 2009-02-26 10:11:43 EST
Fixed in 2.25.2-6.

Note You need to log in before you can comment on or make changes to this bug.