Bug 486852 - Add Remove Program (gpk-application) crashes
Add Remove Program (gpk-application) crashes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 09:39 EST by Igor Lumpus
Modified: 2009-04-01 05:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 05:27:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gpk-application-bugreport.txt (286.54 KB, text/plain)
2009-02-22 09:42 EST, Igor Lumpus
no flags Details

  None (edit)
Description Igor Lumpus 2009-02-22 09:39:19 EST
Description of problem:
Add Remove Program, i.e. gpk-application, crashes due to:
(gpk-application:10768): libglade-WARNING **: could not look up stock id 'Avsluta'
Processen finns inte
6c2c7b3d-a144-6208-3c31eac5-277efadd is dumped


Version-Release number of selected component (if applicable):
gnome-packagekit.i386 0:0.4.3-1.fc11


How reproducible:
Use Fedora 11 (rawhide)
Set locale to Swedish.
Start program from menu or command line.

Steps to Reproduce:
1.Start program as normal user
2.Crashes immediately
3.
  
Actual results:
See gpk-application bugreport for detailed info.


Expected results:
Program should start.


Additional info:
Fedora 11, rawhide, with Swedish locale. Is probably the culprit since the warning from libglade,
  could not look up stock id 'Avsluta'
where Avsluta is Swedish for Exit.
See attached bugreport for detailed info.
Comment 1 Igor Lumpus 2009-02-22 09:42:22 EST
Created attachment 332856 [details]
gpk-application-bugreport.txt

Had to add attachment separately from submitting bug.
Comment 2 Richard Hughes 2009-04-01 05:27:00 EDT
Should be fixed in 6c4cebdcc3a5ebb2ba44af63a1487ba6040b44a4 -- I'll build a new package for rawhide next week unless you want me to add a patch now.

Note You need to log in before you can comment on or make changes to this bug.