Bug 486864 - avr-gcc -mmcu=at90usb1287 fails to find crtusb1287.o
avr-gcc -mmcu=at90usb1287 fails to find crtusb1287.o
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: avr-libc (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Thibault North
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 12:31 EST by Scott Tsai
Modified: 2009-02-23 07:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-23 07:11:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2009-02-22 12:31:02 EST
Description of problem:
"avr-gcc -mmcu=at90usb1287" fails because it can't find crtusb1287.o


Version-Release number of selected component (if applicable):
avr-gcc-4.3.3-1.fc10.x86_64
avr-libc-1.4.6-4.fc8.noarch
avr-binutils-2.18-2.fc9.x86_64

How reproducible:
always.

Steps to Reproduce:
1. avr-gcc -Wall -Os -g -mmcu=at90usb1287 -DF_CPU=16000000UL blink.c -o blink

Actual results:
/usr/lib/gcc/avr/4.3.3/../../../../avr/bin/ld: crtusb1287.o: No such file: No such file or directory


Expected results:
No output.

Additional info:
1. Compiling works if I do:
sudo ln -s avr5 /usr/avr/lib/avr51
I found out that avr-gcc looks for crtusb1287.o under /usr/avr/lib/avr51 through the "strace" utility.

2. Since interesting projects like "lufa":
http://www.fourwalledcubicle.com/LUFA.php
now requires avr-libc-1.6.2 or newer I'd really appreciate an update of avr-libc.
Comment 1 Thibault North 2009-02-22 19:22:16 EST
avr-libc-1.6.4 is in the pending updates since 2009-02-19:
https://admin.fedoraproject.org/updates/avr-libc-1.6.4-1.fc10

It should fix the problem.
Comment 2 Thibault North 2009-02-22 19:29:41 EST
BTW, the noarch RPM is available here:
http://tnorth.fedorapeople.org/FEL/avr-libc-1.6.4-1.fc11.noarch.rpm
Comment 3 Scott Tsai 2009-02-23 07:11:24 EST
Thanks for the quick reply. I'm now happily using avr-libc-1.6.4-1.fc11.noarch.rpm to build lufa on my at90usb1287 board :) Closing this bug as I expect the avr-libc-1.6.4 update is on its way to Fedora 10.

Note You need to log in before you can comment on or make changes to this bug.