This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 486866 - qt-4.5.0: lupdate segfault
qt-4.5.0: lupdate segfault
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 12:47 EST by Kevin Kofler
Modified: 2009-03-16 19:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 19:56:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
scidavis.pro that induces segfaults (6.60 KB, text/plain)
2009-02-22 13:41 EST, Rex Dieter
no flags Details

  None (edit)
Description Kevin Kofler 2009-02-22 12:47:30 EST
+++ This bug was initially created as a clone of Bug #485677 +++

Description of problem:
a package build fine for F-10 : http://koji.fedoraproject.org/koji/taskinfo?taskID=1128601 and the same package fail for rawhide : http://koji.fedoraproject.org/koji/taskinfo?taskID=1128665 
It could be due to the recent introduction of qt-4.5-rc1 in rawhide ?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Kofler 2009-02-22 12:49:25 EST
CCing original reporter (Eric Tanguy).
Comment 2 Rex Dieter 2009-02-22 13:33:08 EST
Reproduced locally:

/bin/sh: line 1: 19764 Segmentation fault      lupdate-qt4 scidavis.pro

lupdate crasher it seems.
Comment 3 Rex Dieter 2009-02-22 13:38:46 EST
Fwiw, both:
lupdate scidavis.pro
and 
lrelease scidavis.pro
segfault
Comment 4 Rex Dieter 2009-02-22 13:41:54 EST
Created attachment 332863 [details]
scidavis.pro that induces segfaults
Comment 5 Eric Tanguy 2009-02-26 16:17:52 EST
same problem with older scidavis version during mass rebuild 
http://koji.fedoraproject.org/koji/taskinfo?taskID=1178310
Comment 6 Rex Dieter 2009-02-26 16:27:24 EST
I'm testing out the latest 20090224 qt snapshot, cross your fingers.
Comment 7 Rex Dieter 2009-02-27 14:31:53 EST
rats 20090224 segfaults too.
Comment 8 Rex Dieter 2009-03-13 12:42:03 EDT
confirmed on 4.5.0 too.
Comment 9 Eric Tanguy 2009-03-13 13:57:07 EDT
Ok what could be the problem ?
Is it a scidavis problem ?
Comment 10 Ngo Than 2009-03-16 19:56:35 EDT
it's fixed in qt-4_5_0-6_fc11.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1245001

Note You need to log in before you can comment on or make changes to this bug.