Bug 486883 - patch to fix epel compilation
patch to fix epel compilation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gstreamer-python (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 17:18 EST by Levente Farkas
Modified: 2009-04-16 19:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 12:10:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2009-02-22 17:18:59 EST
please apply the patch bellow to be able to compile on epel-5 and older
fedoras.
thanks.
yours
-------------------------------------------------
--- gstreamer-python.spec	2009-01-30 12:16:43.000000000 +0100
+++ gstreamer-python.spec.new	2009-02-22 23:17:07.000000000 +0100
@@ -75,7 +75,9 @@
 %{_libdir}/python?.?/site-packages/gst-%{majorminor}
 %{_libdir}/python?.?/site-packages/pygst.py*
 %{_libdir}/python?.?/site-packages/pygst.pth
+%if 0%{?fedora} >= 9
 %{_libdir}/python?.?/site-packages/gstoption.so
+%endif
 %dir %{_datadir}/gst-python
 %dir %{_datadir}/gst-python/%{majorminor}
 %dir %{_datadir}/gst-python/%{majorminor}/defs
-------------------------------------------------
Comment 1 Levente Farkas 2009-04-12 17:43:30 EDT
ping...
Comment 2 Denis Leroy 2009-04-14 12:10:34 EDT
There is an EPEL branch for gstreamer-python. Is that not working ? Or do you need the EPEL version upgraded ?
Comment 3 Levente Farkas 2009-04-16 13:00:28 EDT
imho it'd be useful if all fedora rawhide rpms can be recompiled on epel. 
this patch made it possible to rebuild the latest rawhide gstreamer-python on el5 so imho this patch would be useful (as not hurt the fedora compilation).
Comment 4 Denis Leroy 2009-04-16 19:09:21 EDT
I understand your point, but I really dislike carrying release/distro related macros in spec files, since it defeats the purpose of having branches for each distros we support. The EPEL version should do the job. If it doesn't, we can talk about upgrading it certainly.

Note You need to log in before you can comment on or make changes to this bug.