Bug 486899 - "echo disk>/sys/power/state " cause kernel panic when system trying to sleep down
"echo disk>/sys/power/state " cause kernel panic when system trying to sleep ...
Status: CLOSED DUPLICATE of bug 490192
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Milburn
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 22:47 EST by jessie ye
Modified: 2009-07-31 08:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-31 08:38:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the trace about kernel panic and system info (2.70 KB, application/x-zip-compressed)
2009-02-22 22:47 EST, jessie ye
no flags Details

  None (edit)
Description jessie ye 2009-02-22 22:47:17 EST
Created attachment 332896 [details]
the trace about kernel panic and system info

Description of problem:
"echo disk>/sys/power/state " cause kernel panic when system trying to sleep down

Version-Release number of selected component (if applicable):
Linux localhost.localdomain 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:14 EST 2007 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
easy to reproduce

Steps to Reproduce:
1.Fresh install RHEL50 x86_64 on SATA Disk
2.echo disk>/sys/power/state
3.kernel panic when system is tring to sleep down
  
Actual results:
system Kernel Panic

Expected results:
Sleep down 

Additional info:
Build vanila kernel 2.6.18 and do the same test, system can sleep down normally.
Motherboard: ASUS M2N32-SLI
Comment 1 David Milburn 2009-02-27 14:08:03 EST
Hello,

I did a quick test on x86_64 system with RHEL 5.3 (2.6.18-128.el5) on a SAS
disk, the suspend/resume worked correctly. However, when I installed and
booted the 2.6.18-8.el5 kernel the system did get a softlockup during suspend,
this is more likely a power management or acpi bug rather than a sata bug.
I will need to review the power management and acpi changes between the -8.el5
kernel and the -128.el5 kernel, it is very possible that the problem you are
seeing has been addressed in a later kernel.
Comment 2 Larry Troan 2009-03-13 11:25:33 EDT
Suggest you try the 5.3 kernel as well to see if the problem still occurs. Per comment #1, it appears this may have been fixed. 

Please report results here.

There were major changes in the power management code in 5.1 to support notebooks and minor changes in 5.2 and 5.3 as well.
Comment 3 Larry Troan 2009-07-31 08:38:49 EDT
DUPing to bug 490192 since this is where all the activity has occurred.

*** This bug has been marked as a duplicate of bug 490192 ***

Note You need to log in before you can comment on or make changes to this bug.