Bug 486925 - Cannot enable external monitor with xrandr (starting with 6.10.0-1)
Cannot enable external monitor with xrandr (starting with 6.10.0-1)
Status: CLOSED DUPLICATE of bug 484636
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 04:37 EST by Adrian Reber
Modified: 2018-04-11 03:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 16:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log with xorg-x11-drv-ati-6.9.0-64.fc10.i386 (441.31 KB, text/plain)
2009-03-13 04:56 EDT, Adrian Reber
no flags Details
Xorg.0.log with xorg-x11-drv-ati-6.10.0-2.fc10.i386 (481.85 KB, text/plain)
2009-03-13 05:09 EDT, Adrian Reber
no flags Details
Xorg.0.log with xorg-x11-drv-ati-6.10.0-2.fc10.i386 and nomodeset (280.89 KB, text/plain)
2009-03-13 05:18 EDT, Adrian Reber
no flags Details

  None (edit)
Description Adrian Reber 2009-02-23 04:37:40 EST
Description of problem:
Since upgrading to xorg-x11-drv-ati-6.10.0-1.fc10.i386 (also 6.10.0-2) I cannot enable the external monitor connected to the docking station of my Lenovo T400. Going back to xorg-x11-drv-ati-6.9.0-64.fc10 makes it work again.

My xrandr call "xrandr --output DVI-0 --right-of LVDS --auto" does not enable the external monitor and the panel of the T400 shows only lots of different colors. CTRL-ALT-BACKSPACE after removing it from the docking station starts X again as expected.

How reproducible:
Every tim

Steps to Reproduce:
xrandr --output DVI-0 --right-of LVDS --auto
  
Additional info:
01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series
Comment 1 Matěj Cepl 2009-02-25 11:11:52 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 François Cami 2009-03-11 17:43:22 EDT
Adrian,

Could you provide the information asked by Matej above ?
Also, could you try booting with nomodeset as a kernel
parameter and see if it alleviates the problem.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adrian Reber 2009-03-13 04:53:39 EDT
I have no xorg.conf.

I will add the Xorg.log files as attachments.
Comment 4 Adrian Reber 2009-03-13 04:56:01 EDT
Created attachment 335064 [details]
Xorg.0.log with xorg-x11-drv-ati-6.9.0-64.fc10.i386

This is the log file where xrandr still works.
Comment 5 Adrian Reber 2009-03-13 05:09:50 EDT
Created attachment 335065 [details]
Xorg.0.log with xorg-x11-drv-ati-6.10.0-2.fc10.i386

logfile from xorg-x11-drv-ati-6.10.0-2.fc10.i386 where xrandr does not work.

Instead of both monitor woriking the LVDS get all white with colourful stripes and it starts very bright and gets darker within 10 seconds.

I can blindly type "xrandr --output DVI-0 --off" which normally turns the external DVI monitor off again and only enables LVDS, this change the LVDS to black again but nothing else can be seen.

CTRL-ALT-BACKSPACE restarts X without problems.
Comment 6 Adrian Reber 2009-03-13 05:18:46 EDT
Created attachment 335066 [details]
Xorg.0.log with xorg-x11-drv-ati-6.10.0-2.fc10.i386 and nomodeset

Tried it with nomodeset. No difference. Same error symptoms. But as my ATI is not supported (too new) by kernel mode setting in F10, I did not expect a difference.
Comment 7 François Cami 2009-03-13 16:26:02 EDT
Adrian,

Thanks for the logs.
Marking as DUP of # 484636 after examining diff from both Xorg logs.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 484636 ***

Note You need to log in before you can comment on or make changes to this bug.