This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 486998 - Wishlist: add "okular" to bash-completion
Wishlist: add "okular" to bash-completion
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bash-completion (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 11:31 EST by Mary Ellen Foster
Modified: 2009-05-02 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-02 12:26:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2009-02-23 11:31:46 EST
Description of problem:
It would be very nice if "okular", the new document-viewing component in KDE4, were included in bash-completion. As far as I can tell, it can display basically the same file types as evince, so copying that line should suffice.

I initially tried creating a ~/.bash_completion file with the okular completion I wanted, but there's some magic in /etc/bash_completion that I was unable to reproduce. Documentation on how to add new completions using filedir_xspec would also be helpful. :)
Comment 1 Ville Skyttä 2009-02-23 12:32:33 EST
It seems to me that okular supports more file types than evince, but adding the evince types is a good start.  Done upstream: http://git.debian.org/?p=bash-completion/bash-completion.git;a=commitdiff;h=7bc9c43b1efa06940d884f018612a9e2ff13f849

Regarding filedir_xspec, it's a hairy hack present for bash < 3 compatibility and will be going away soonish, you probably don't want to have anything to do with it ;)

Instead, if you have only filename extensions to complete on, you could just use something like

    complete -f -o plusdirs -X '!*.foo' bar

...or if you have a completion function that does something in addition to filename completion, use _filedir in it (there are many examples in /etc/bash_completion and /usr/share/bash-completion/).
Comment 2 Ville Skyttä 2009-03-15 15:34:39 EDT
Done in 20080705-3.20090314gitf4f0984 for F-11, will be in the next F-10 update as well.
Comment 3 Fedora Update System 2009-04-13 09:11:39 EDT
bash-completion-1.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/bash-completion-1.0-2.fc10
Comment 4 Fedora Update System 2009-04-13 09:13:01 EDT
bash-completion-1.0-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/bash-completion-1.0-2.fc9
Comment 5 Fedora Update System 2009-04-14 11:51:54 EDT
bash-completion-1.0-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bash-completion'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3639
Comment 6 Fedora Update System 2009-04-14 11:52:11 EDT
bash-completion-1.0-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update bash-completion'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3640
Comment 7 Fedora Update System 2009-05-02 12:25:49 EDT
bash-completion-1.0-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-05-02 12:30:20 EDT
bash-completion-1.0-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.