Bug 487 - RPM's Oboletes: tag is broken when you include versions
Summary: RPM's Oboletes: tag is broken when you include versions
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-15 20:11 UTC by Preston Brown
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-30 02:41:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Preston Brown 1998-12-15 20:11:58 UTC
RPMs obsoletes: tag used to be able to handle version
numbers, but now it appears it can't.  For instance:

Obsoletes: foo <= 1.0

used to work fine.  It no longer does.  This produces the
complaint:

Obsoletes: tokens must begin with alpha-numeric

Comment 1 Jeff Johnson 1998-12-30 02:41:59 UTC
Versions in Provides/Obsoletes have never worked -- the
token <= used to be silently treated as a virtual package
name. Later versions of rpm now require packages to start
with an alphabetic.


Note You need to log in before you can comment on or make changes to this bug.