Bug 487028 - Default to USB tablet for Fedora 11 guests
Default to USB tablet for Fedora 11 guests
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On: 487025
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-02-23 13:30 EST by Daniel Berrange
Modified: 2009-09-15 03:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.400.3-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 11:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of a test rawhide install (4.72 KB, text/plain)
2009-03-07 12:48 EST, Julian Sikorski
no flags Details

  None (edit)
Description Daniel Berrange 2009-02-23 13:30:07 EST
Description of problem:
Fedora 11 will automatically support QEMU's USB tablet out of the box with zero configuration required. Thus we should turn this on by default for all F11 & later installs done by virt-install & virt-manager.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Use virt-manager to install an F11 guest
2.
3.
  
Actual results:
PS2 is currently used, requiring client mouse grab.

Expected results:
USB tablet is enabled, and mouse can be used in VNC console without it being grabbed


Additional info:
Comment 1 Cole Robinson 2009-02-23 19:12:07 EST
Applied upstream:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/65294f71833d

Moving to POST.
Comment 2 Daniel Berrange 2009-02-27 07:05:31 EST
Built it into rawhide with  python-virtinst-0.400.1-3.fc11 and for an F10 update as python-virtinst-0.400.0-6.fc10
Comment 3 Fedora Update System 2009-02-27 07:06:52 EST
python-virtinst-0.400.0-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/python-virtinst-0.400.0-6.fc10
Comment 4 Fedora Update System 2009-02-27 22:28:58 EST
python-virtinst-0.400.0-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2206
Comment 5 Fedora Update System 2009-03-04 11:51:51 EST
python-virtinst-0.400.2-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/python-virtinst-0.400.2-1.fc10
Comment 6 Fedora Update System 2009-03-05 11:33:18 EST
python-virtinst-0.400.2-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2403
Comment 7 Julian Sikorski 2009-03-07 06:56:34 EST
While 0.400.0-6.fc10 did set up the tablet properly, 0.400.2-1.fc10 no longer does.
I used the following command:
virt-install --os-type=linux --location=http://sunsite.icm.edu.pl/pub/Linux/fedora/linux/development/i386/os/ --name=rawhide-i586 --vcpus=1 --file=/var/lib/libvirt/images/rawhide-i586.img --accelerate --nonsparse --ram=512 --file-size=10 --arch=x86_64 --hvm --sound --os-variant=fedora11
Comment 8 Cole Robinson 2009-03-07 12:01:11 EST
Thanks for testing this.

Seems to work here (at least on the virt-install side). Can see if 'virsh dumpxml {VMNAME} | grep tablet' returns anything? If so, it's probably a problem inside the guest. Otherwise, please post ~/.virtinst/virt-install.log. Thanks.
Comment 9 Julian Sikorski 2009-03-07 12:48:04 EST
Created attachment 334404 [details]
log of a test rawhide install

The virsh command output did not contain 'tablet' phrase. I am thus attaching the log. The installation was killed during install.img download.
Comment 10 Julian Sikorski 2009-03-07 13:24:58 EST
For reference, the problem occurs with python-virtinst-0.400.2-2.fc10.noarch, not 0.400.2-1.fc10 Sorry for the confusion.
Comment 11 Cole Robinson 2009-03-07 17:00:33 EST
Okay, looks like this is particular to URL installs: we override a user passed os-type with the one detected from the URL tree, which happens to also wipe out the passed os-variant :( (and has been busted since 0.400.1). The following two upstream csets give the complete fix:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/1842b7b829ee
http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/fa15b5e5d82a

I'll build fixed packages soon. Thanks again for the report.
Comment 12 Cole Robinson 2009-03-09 01:26:26 EDT
I'm actually going to be cutting a virtinst bugfix release on Tuesday, which will include the fix (and a few other embarrassing ones I've found). I'll hold off on building the packages until then.
Comment 13 Fedora Update System 2009-03-10 01:25:13 EDT
python-virtinst-0.400.3-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/python-virtinst-0.400.3-1.fc10
Comment 14 Fedora Update System 2009-03-11 14:01:52 EDT
python-virtinst-0.400.3-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2612
Comment 15 Mark McLoughlin 2009-04-06 11:03:50 EDT
This bug is filed against rawhide and its fixed there, so closing.
Comment 16 Fedora Update System 2009-09-15 03:52:03 EDT
python-virtinst-0.400.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.