Bug 487056 - weird << marker breaks at scripts
weird << marker breaks at scripts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: at (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 16:08 EST by Jonathan Kamens
Modified: 2009-02-26 08:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 08:52:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2009-02-23 16:08:11 EST
When I queue an at job consisting of nothing but a one-line echo command "echo foo", here's what the resulting file in /var/spool/at looks like:

${SHELL:-/bin/sh} << `(dd if=/dev/urandom count=200 bs=1 2>/dev/null|LC_ALL=C tr -d -c '[:alnum:]')`

echo foo

I don't know where that garbage after the << is coming from, but it's clearly completely borked, and when the at job runs, I see this:

sh: line 63: warning: here-document at line 60 delimited by end-of-file (wanted ``(dd if=/dev/urandom count=200 bs=1 2>/dev/null|LC_ALL=C tr -d -c [:alnum:])`')

I'm current from rawhide, including at-3.1.10-27.fc11.i386.
Comment 1 Marcela Mašláňová 2009-02-24 06:40:25 EST
This line is supposed to run _at_ non-bash scripts. I blame for this changes in bash-4.0.
Comment 2 Marcela Mašláňová 2009-02-24 09:41:36 EST
Ok, it's bash #485664.

I change the delimiter to something else.
Comment 3 Marcela Mašláňová 2009-02-26 08:52:26 EST
Fixed in at-3.1.10-30.fc11

Note You need to log in before you can comment on or make changes to this bug.