Bug 487073 - Logic error in definition of ATTRIBUTE_PRINTF
Logic error in definition of ATTRIBUTE_PRINTF
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 19:42 EST by Ignacio Vazquez-Abrams
Modified: 2009-04-17 05:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 05:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to remove excess ATTRIBUTE_PRINTF definitions (1.60 KB, patch)
2009-02-23 19:49 EST, Ignacio Vazquez-Abrams
no flags Details | Diff

  None (edit)
Description Ignacio Vazquez-Abrams 2009-02-23 19:42:55 EST
libxml2.i386 0:2.7.3-1.fc11

Line 422 of /usr/include/libxml2/libxml/xmlversion.h checks to see if ATTRIBUTE_PRINTF is not defined. If it is then it falls through to line 429, where it promptly proceeds to redefine it. This causes an issue when a wxGTK app is built since wxGTK defines its own ATTRIBUTE_PRINTF. One example of such an app is xmlcopyeditor 1.2.0.2, which I am trying to build for Rawhide.
Comment 1 Ignacio Vazquez-Abrams 2009-02-23 19:49:09 EST
Created attachment 332994 [details]
Patch to remove excess ATTRIBUTE_PRINTF definitions

I also found another definition after. This patch should fix this issue.
Comment 2 Daniel Veillard 2009-04-17 05:10:41 EDT
Fixed in a completely different way upstream, see
http://mail.gnome.org/archives/xml/2009-April/msg00021.html

thanks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.