This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 487078 - FTBFS nted dist-f11: silent Qt ABI change breaks kdesdk/po2xml tool
FTBFS nted dist-f11: silent Qt ABI change breaks kdesdk/po2xml tool
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nted (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans Ulrich Niedermann
Fedora Extras Quality Assurance
:
Depends On: 487075
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 20:12 EST by Hans Ulrich Niedermann
Modified: 2009-03-03 18:01 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.5.0-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 18:01:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans Ulrich Niedermann 2009-02-23 20:12:18 EST
Description of problem:

  nted's build fails while building the documentation.

  This calls po2xml from the kdesdk-utils package, which
  is broken in connection with newer qt versions (bug 487075).

Version-Release number of selected component (if applicable):

  nted-1.4.17-1
  nted-1.5.0-1
  and others

How reproducible:

  100%

Steps to Reproduce:
1. cd nted/devel
2. make scratch-build
  
Actual results:

/usr/bin/po2xml ./../en/index.docbook ./de.po >index.docbook
Unknown feature http://trolltech.com/xml/features/report-start-end-entity
can't find
You cannot really "delete" a rest because you cannot destroy time. But in many cases the situation is as follows: <mediaobject> <imageobject> <imagedata fileref="../docimages/delete_rests1.png" format="PNG"/> </imageobject> <textobject><phrase>shift example 1</phrase> </textobject> </mediaobject> This can especially happen after deleting a series of notes because every deleted note leaves behind an appropriate rest. If you now <emphasis>insert</emphasis> a half rest at position of the first eighth rest the situation changes:
in
You cannot really "delete" a rest because you cannot destroy time. But in many cases the situation is as follows: <mediaobject> <imageobject> <imagedata fileref="../docimages/delete_rests1.png" format="PNG"/> </imageobject> <textobject><phrase>shift example 1</phrase> </textobject> </mediaobject> This can especially happen after deleting a series of notes because every deleted note leaves behind an appropriate rest. If you now <emphasis>insert</emphasis> a half rest at position of the first eighth rest the situation changes: <mediaobjec
make[3]: 
*** [index.docbook] Error 1

Expected results:

  Successful build.

Additional info:
Comment 1 Hans Ulrich Niedermann 2009-02-26 06:28:52 EST
I am waiting for the qt package maintainer to react to bug 487075.

Once bug 487075 has been fixed to be compatible with po2xml again, the nted build will succeed again.

Note You need to log in before you can comment on or make changes to this bug.