Bug 487089 - File browsing becomes very slow with KDE4 Konqueror and Dolphin
File browsing becomes very slow with KDE4 Konqueror and Dolphin
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: soprano (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 22:14 EST by Brian Daniels
Modified: 2009-04-28 15:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 01:50:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace crashing when tracing konqueror hang (8.67 KB, text/plain)
2009-03-15 12:44 EDT, Brian Daniels
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 172176 None None None Never

  None (edit)
Description Brian Daniels 2009-02-23 22:14:44 EST
Description of problem:
When I first login to my KDE4 system, Konqueror browses directories very quickly.  But after a little system use, it will slow to a crawl, taking 10 sec to show the home directory, and 1:20 to display a directory with 600 files in it.  Once this starts, Dolphin exhibits the same behavior.

During this delay, top shows konqueror only taking 1-2% of CPU.  Trying to close konqueror during the delay will bring up the 'not responding' dialog.  An 'ls' of the same dir is instant.

I attempted a 'strace konqueror --profile filemanagement' to see what was going on.  The last few lines of the trace:

stat("/var/tmp/kdecache-bdaniels/kpc/kde-icon-cache.data", {st_mode=S_IFREG|0664, st_size=16240640, ...}) = 0
stat("/var/tmp/kdecache-bdaniels/kpc/kde-icon-cache.data", {st_mode=S_IFREG|0664, st_size=16240640, ...}) = 0
stat("/var/tmp/kdecache-bdaniels/kpc/kde-icon-cache.data", {st_mode=S_IFREG|0664, st_size=16240640, ...}) = 0
select(Aborted
$

Closing and restarting konqueror does not fix the problem.  Logging out and back in usually does.  Sometimes it will 'fix itself' during a session, then go bad again.  The same hardware did not exhibit this problem with F8/KDE3.
Comment 1 Brian Daniels 2009-03-15 12:44:24 EDT
Created attachment 335261 [details]
strace crashing when tracing konqueror hang
Comment 2 Brian Daniels 2009-03-15 12:47:16 EDT
The problem is still present after recent updates.  I attempted a strace -p as
root of the running user process, and saw a ton of the following messages
during the hang:

read(8, 0x1c96ce4, 4096)                = -1 EAGAIN (Resource temporarily
unavailable) 

I attempted more traces to try and track down what file was involved, but now
just moving the mouse pointer over the konqueror window causes strace to exit
with a *** glibc detected *** strace: malloc(): memory corruption (fast):
0x0000000000c10610 ***

I have attached the trace attempt file.  The filesystem of /home is ext4, if
that has any relevance.
Comment 3 Steven M. Parrish 2009-03-16 20:24:08 EDT
Thank you for the bug report.  This issue needs to be addressed by the upstream developers.  Please submit a report at http://bugs.kde.org. You are requested to add the bugzilla link here for tracking purposes. Please make sure the bug isn't already in the upstream bug tracker before filing it.
Comment 4 Brian Daniels 2009-03-16 22:28:14 EDT
After more digging, found that disabling Nepomuk/Strigi made the bug go away.  May be related to:
https://bugs.kde.org/show_bug.cgi?id=172176
and linked there.
Comment 5 Kevin Kofler 2009-03-17 01:50:28 EDT
Yes, looks like it, we'll continue tracking this upstream.
Comment 6 Brian Daniels 2009-04-28 13:56:46 EDT
KDE devs responded as follows:

"it's a Redland issue, not a Java issue, we still don't have Sesame2 in Fedora because packaging it according to Fedora's guidelines is months of work (the package in kde-redhat unstable uses the binary JARs and is thus not acceptable in Fedora)."


I've been working around it by disabling Nepomuk.  It sounds like no fix is intended upstream until/unless Sesame2 is in Fedora.
Comment 7 Rex Dieter 2009-04-28 14:38:03 EDT
Sad state of affairs, indeed.  Let's look forward to kde-4.3 and virtuoso I guess.

Note You need to log in before you can comment on or make changes to this bug.