Bug 487104 - Duplicate files with kdelibs3
Duplicate files with kdelibs3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 487292 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 03:48 EST by Mamoru TASAKA
Modified: 2009-03-04 18:58 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 15:00:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2009-02-24 03:48:33 EST
Description of problem:
# LANG=C yum -y upgrade --disablerepo=koji-10 kde\*
Loaded plugins: dellsysidplugin2
Setting up Upgrade Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package kdelibs.i586 6:4.2.0-15.fc11 set to be updated
---> Package kdelibs-common.i586 6:4.2.0-15.fc11 set to be updated
---> Package kdelibs-devel.i586 6:4.2.0-15.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved
============================================================
 Package         Arch    Version           Repository   Size
============================================================
Updating:
 kdelibs         i586    6:4.2.0-15.fc11   koji-11      14 M
 kdelibs-common  i586    6:4.2.0-15.fc11   koji-11     275 k
 kdelibs-devel   i586    6:4.2.0-15.fc11   koji-11     1.8 M

Transaction Summary
============================================================
Install      0 Package(s)         
Update       3 Package(s)         
Remove       0 Package(s)         

Total size: 16 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/bin/preparetips from install of kdelibs-6:4.2.0-15.fc11.i586 conflicts with file from package kdelibs3-3.5.10-5.fc11.i386
  file /usr/share/config/colors/40.colors from install of kdelibs-6:4.2.0-15.fc11.i586 conflicts with file from package kdelibs3-3.5.10-5.fc11.i386
  file /usr/share/config/colors/Rainbow.colors from install of kdelibs-6:4.2.0-15.fc11.i586 conflicts with file from package kdelibs3-3.5.10-5.fc11.i386
  file /usr/share/config/colors/Royal.colors from install of kdelibs-6:4.2.0-15.fc11.i586 conflicts with file from package kdelibs3-3.5.10-5.fc11.i386
  file /usr/share/config/colors/Web.colors from install of kdelibs-6:4.2.0-15.fc11.i586 conflicts with file from package kdelibs3-3.5.10-5.fc11.i386
  file /usr/share/config/ksslcalist from install of kdelibs-6:4.2.0-15.fc11.i586 conflicts with file from package kdelibs3-3.5.10-5.fc11.i386

By the way even now these files are owned by both two,
e.g.
$ rpm -qf /usr/bin/preparetips
kdelibs3-3.5.10-5.fc11.i386
kdelibs-4.2.0-13.fc11.i586

Now these files are regarded as "Conflicts" because these two rpms use 
different hash checksum. Perhaps rebuilding kdelibs3 with new
redhat-rpm-config will solve this issue, however to begin with
is it intentional that these files are owned by two packages?

Version-Release number of selected component (if applicable):
kdelibs3-3.5.10-5.fc11.i386
kdelibs-4.2.0-15.fc11.i586

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.
Comment 1 Kevin Kofler 2009-02-24 10:09:11 EST
Looks like we need to move those files to kdelibs-common or remove them from one of the packages.

/usr/bin/preparetips looks like a developer script:
# little script to extract the text from the tips file
# and output it, so xgettext can add the tips to the po file
I don't think it's ever used at runtime, so it should be only in one of the -devel packages, if we want to ship it at all.

/usr/share/config/colors and /usr/share/config/ksslcalist should go to kdelibs-common.
Comment 2 Rex Dieter 2009-02-25 10:10:10 EST
*** Bug 487292 has been marked as a duplicate of this bug. ***
Comment 3 Mamoru TASAKA 2009-03-04 15:00:21 EST
[root@localhost ~]# rpm -q kdelibs3 kdelibs
kdelibs3-3.5.10-9.fc11.i586
kdelibs-4.2.1-2.fc11.i586
[root@localhost ~]# rpm -ql kdelibs kdelibs3 | sort | uniq -d 
/usr/lib/kconf_update_bin
/usr/share/config/colors
/usr/share/config/ui

These are all directories, so now I close this bug as RAWHIDE.
Comment 4 Rex Dieter 2009-03-04 15:14:21 EST
Ideally, those 3 could/should also be in kdelibs-common as well, but that's not a big deal.
Comment 5 Kevin Kofler 2009-03-04 18:58:51 EST
/usr/lib/kconf_update_bin is under libdir, putting that into kdelibs-common would require us to make it arch-specific (it's currently noarch).

Note You need to log in before you can comment on or make changes to this bug.