Bug 487130 - the dellsysid plugin gets installed on a bunch of systems, even ones where it has no business
the dellsysid plugin gets installed on a bunch of systems, even ones where it...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firmware-addon-dell (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael E Brown
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 08:43 EST by seth vidal
Modified: 2013-07-28 21:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-11 22:47:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description seth vidal 2009-02-24 08:43:10 EST
Description of problem:
Seen a lot of bug reports with the delsysid plugin running, most recently on an XO-1. Clearly not a dell system. We've gotten a few bug reports on systems where the dellsysid plugin is what is hanging up the rest of the system from running.

I think the plugin should be  broken out to another package and/or broken out of the Hardware Support comps group as that seems to be how it is being drawn in.
Comment 1 Matt Domsch 2009-05-16 11:17:21 EDT
The dellsysid plugin lives in the firmware-addon-dell package.  Not sure how it would be getting pulled in unless explicitly requested by a user.  Unless something is installing firmware* and thus pulling it in.
Comment 2 Matt Domsch 2009-05-16 11:31:23 EDT
firmware-addon-dell is listed as optional in comps-f11.  So it shouldn't be getting pulled in.
Comment 3 Matt Domsch 2009-05-16 11:42:00 EDT
and it's not pulled into the Fedora 10 livecd.
Comment 4 Matt Domsch 2009-05-18 13:33:25 EDT
I spoke with Michael Brown this morning.  firmware-addon-dell is dropping the dellsysid plugin.  It has moved to the libsmbios package, and is (in F11 gold) included in the smbios-utils-python package.  That's still not ideal.

The plugin is going to remain in the libsmbios SRPM, but I'll split it out into a separate subpackage, yum-dellsysid.  The things that will Require: yum-dellsysid are all Dell-specific yum repository configuration RPMs posted on linux.dell.com.   When this happens, no other packages in Fedora will Require yum-dellsysid, so it will drop from people's systems on upgrade, never to bother non-Dell users again.

Seem sane?
Comment 5 Bug Zapper 2009-06-09 07:37:05 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Frank Cox 2009-08-03 20:15:57 EDT
I see "loading dellsysid plugin" every time I run yum on my Acer Aspire One netbook.  It's running F11, upgraded from F10 with preupgrade.

I have never knowingly added dell-anything to that computer, so where-ever it came from, it showed up by magic.

It's never affected anything that I've noticed, though, other than tell me that it's loading.  Yum works fine after that message goes by.
Comment 7 John Aldrich 2009-08-04 00:15:22 EDT
I, too, have a 100% NON-DELL box which has this plugin in F11 (upgraded from F10.) It does not appear to be causing any problems, however, there doesn't seem to be any reason for this. I also do NOT have any Dell repos installed, so that's not the reason either.
Comment 8 Matt Domsch 2009-08-04 10:53:15 EDT
Yes, we know where it's coming from.  It was part of libsmbios, which was a requirement of hal in the Fedora 10 timeframe.  hal is of course a manditory component, therefore it pulled in libsmbios, which then pulled in the dellsysid plugin.

In Fedora 11, hal no longer Requires: libsmbios.  So fresh F11 installs, dellsysidplugin won't get installed.  And I've made changes to the upstream libsmbios packaging to put the yum plugin into its own subpackage.
Comment 9 Matt Domsch 2009-12-11 22:47:55 EST
Built into rawhide today, libsmbios-2.2.19.

The plugin moved to a separate sub-package in libsmbios, yum-dellsysid.

Closing.

Note You need to log in before you can comment on or make changes to this bug.