Bug 487133 - setsysfont does not respect LC_CTYPE
setsysfont does not respect LC_CTYPE
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 08:55 EST by Stepan Kasal
Modified: 2014-03-16 23:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: 8.86.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 17:04:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
my patch (465 bytes, patch)
2009-02-24 08:55 EST, Stepan Kasal
no flags Details | Diff

  None (edit)
Description Stepan Kasal 2009-02-24 08:55:26 EST
Created attachment 333046 [details]
my patch

Description of problem:
my /etc/sysconfig/i18n sets LC_CTYPE, but not LANG
then the console is not switched to Unicode mode.

The problem is that /sbin/setsysfont script does not check LC_CTYPE.
Proposed patch attached.
Comment 1 Matěj Cepl 2009-02-24 08:57:36 EST
There is nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever they want to do with it.
Comment 2 Bill Nottingham 2009-03-20 17:07:28 EDT
You have CTYPE (for the charset) and LANG different? Why not just set the charset as part of the LANG?
Comment 3 Stepan Kasal 2009-03-24 12:29:50 EDT
(In reply to comment #2)
> You have CTYPE (for the charset) and LANG different? Why not just set the
> charset as part of the LANG?  

Well, because I do want to set LC_CTYPE, but not the other LC_* variables.

I need LC_NUMERIC=POSIX, so that no thousands delimiters is used, I need LC_MESSAGES=POSIX, so that I get the error messages intranslated, etc.
Indeed, of all the LC_*, I want to set LC_CTYPE only.

All these LC_* are independent, LANG is a default for unset ones, and LC_ALL, if set overrides all of them.

When you think about it, the console font should indeen depend on the LC_CTYPE ("Character cassification") than on LANG ("The default value for internationalization variables that are unset or null").
Comment 4 Bill Nottingham 2009-03-24 17:04:55 EDT
http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=bb45289856fe0027bb62f024b01802f1eccf5142

Also cherry-picked to the F10-branch.
Comment 5 Fedora Update System 2009-04-02 14:04:15 EDT
initscripts-8.86.1-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.1-1
Comment 6 Fedora Update System 2009-04-03 00:15:56 EDT
initscripts-8.86.2-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.2-1
Comment 7 Fedora Update System 2009-04-22 16:22:21 EDT
initscripts-8.86.3-1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.