Bug 487137 - Feature Request: squidGuard v.1.4 currently in Rawhide to be packaged for F9
Feature Request: squidGuard v.1.4 currently in Rawhide to be packaged for F9
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: squidGuard (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 09:23 EST by Arthur Dent
Modified: 2009-02-27 22:25 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.4-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 22:22:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthur Dent 2009-02-24 09:23:26 EST
Following discussion with Jon Ciesla in Bug 485535 (see https://bugzilla.redhat.com/show_bug.cgi?id=485535) I would like to request that the version of squidGuard currently undergoing approval in Rawhide be released for F9 as well as F10. (I understand that it is currently planned to be released only for F10).

I cannot upgrade from F9 to F10 at the present time and require the functionality of the 1.4 version (namely the abilty to supress the progress bar output from the database update when running from a script).

Many thanks

Mark
Comment 1 Itamar Reis Peixoto 2009-02-24 09:30:22 EST
if you have a fedora account, then you can download the src.rpm and rebuild it using koji for F-10 and F-9
Comment 2 Arthur Dent 2009-02-24 10:49:05 EST
I don't think I have a fedora account - unless it is the same as this bz account - and I have never done this before. Is there a how-to guide somewhere?

Also Jon says there is still a bug in v4.1. So if possible I would rather have a packaged version.

Thanks for the suggestion though.

Mark
Comment 3 Gwyn Ciesla 2009-02-24 11:03:55 EST
Actually, you don't need a fedora account to get an SRPM from koji, here's the one for 1.4:http://kojipkgs.fedoraproject.org/packages/squidGuard/1.4/1.fc11/src/squidGuard-1.4-1.fc11.src.rpm

Nonetheless, I will be pushing 1.4 to F-9, since there are multiple fixes over 1.3.
Comment 4 Fedora Update System 2009-02-24 11:59:57 EST
squidGuard-1.4-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/squidGuard-1.4-2.fc10
Comment 5 Fedora Update System 2009-02-24 12:00:07 EST
squidGuard-1.4-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/squidGuard-1.4-2.fc9
Comment 6 Fedora Update System 2009-02-25 11:25:52 EST
squidGuard-1.4-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update squidGuard'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-2080
Comment 7 Fedora Update System 2009-02-25 11:27:16 EST
squidGuard-1.4-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update squidGuard'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2092
Comment 8 Arthur Dent 2009-02-25 17:37:24 EST
Jon thank you very much for all your work on this. I can confirm that this release works for me and also fixes the earlier Google rewrite bug.

Thanks again.
Comment 9 Fedora Update System 2009-02-27 22:22:45 EST
squidGuard-1.4-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-02-27 22:25:23 EST
squidGuard-1.4-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.