Bug 487140 - Packages built with rpm-4.6.0-8.fc11 won't install on Fedora 10 x86_64
Packages built with rpm-4.6.0-8.fc11 won't install on Fedora 10 x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 09:26 EST by Michael Young
Modified: 2009-03-08 09:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-08 09:13:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2009-02-24 09:26:06 EST
If I take a package such as http://kojipkgs.fedoraproject.org/packages/kernel/2.6.29/0.147.rc6.fc11/noarch/kernel-doc-2.6.29-0.147.rc6.fc11.noarch.rpm which was built with rpm-4.6.0-8.fc11 and try to install it on Fedora 10 (rpm-4.6.0-0.rc3.1.fc10.x86_64), I get the error
error: unpacking of archive failed on file /usr/share/doc/kernel-doc-2.6.29/Documentation/00-INDEX;49a4014e: cpio: MD5 sum mismatch
I have tried a few such packages and two different machines with the same
cpio: MD5 sum mismatch error. A package built with rpm-4.6.0-7.fc11 will install correctly in the same situation.
Comment 1 Panu Matilainen 2009-02-24 10:06:05 EST
Updating to rpm-4.6.0-1.fc10 fixes this. 

It's been available in updates-testing for some time and just a moment ago pushed to final updates. Until mirrors get synced you might have better luck with pulling from updates-testing.
Comment 2 Panu Matilainen 2009-02-24 10:08:25 EST
Oh and just FYI, the difference doesn't come from rpm-4.6.0-7.fc11 vs rpm-4.6.0-8.fc11 but build configuration change between redhat-rpm-config 9.0.3-6.fc11 and 9.0.3-7.fc11.
Comment 3 Michael Young 2009-02-24 11:01:46 EST
So the problem is that Fedora 11 is now using SHA-256 checksums. I did pull the update from F10 updates-testing and the rpm does now install. Are there any plans to introduce SHA-256 checksum support to Fedora 9 rpm, so that will support these rpms as well?
Comment 4 Panu Matilainen 2009-03-08 09:13:16 EDT
Closing as this is now resolved in generally available updates.

And no, F9 wont get SHA-256 support, backporting is too painful (and risky too).

Note You need to log in before you can comment on or make changes to this bug.