Bug 487198 - gnome-system-monitor has hardcoded Requires: PolicyKit-gnome
gnome-system-monitor has hardcoded Requires: PolicyKit-gnome
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-system-monitor (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 13:13 EST by Kevin Kofler
Modified: 2014-06-18 05:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 13:44:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2009-02-24 13:13:38 EST
Description of problem:
gnome-system-monitor has a hardcoded dependency on PolicyKit-gnome. Is this really necessary? In the KDE spin, we would like to ship PolicyKit-kde instead of PolicyKit-gnome. PolicyKit-kde also implements the org.freedesktop.PolicyKit.AuthenticationAgent service.

(Note that gnome-system-monitor is not included on the current KDE spin.)

Version-Release number of selected component (if applicable):
gnome-system-monitor-0:2.25.91-1.fc11

How reproducible:
Always

Steps to Reproduce:
1. repoquery --repoid=rawhide --whatrequires PolicyKit-gnome
  
Actual results:
gnome-system-monitor requires PolicyKit-gnome.

Expected results:
gnome-system-monitor does not require PolicyKit-gnome.

Additional info:
Maybe a common Provides in both PolicyKit-gnome and PolicyKit-kde is needed?
Comment 1 Kevin Kofler 2009-02-27 12:24:07 EST
In Rawhide, both PolicyKit-gnome and PolicyKit-kde now have:
Provides: PolicyKit-authentication-agent
so you can require this instead of PolicyKit-gnome.
Comment 2 Matthias Clasen 2009-02-27 13:44:47 EST
Turns out gnome-system-monitor actually uses the PolicyKit-gnome GtkAction bits, so this is going to have to remain.
Comment 3 Kevin Kofler 2009-02-27 13:51:27 EST
No problem there, we don't want to ship this one on the KDE spin anyway, KDE has its own system monitor (ksysguard).

Note You need to log in before you can comment on or make changes to this bug.