Bug 487207 - cifs: open-file renames require that FH should be opened with SYNCHRONIZE bit set
cifs: open-file renames require that FH should be opened with SYNCHRONIZE bit...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Jeff Layton
Red Hat Kernel QE team
cthon09
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 14:13 EST by Jeff Layton
Modified: 2009-03-04 09:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 09:16:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2009-02-24 14:13:57 EST
Discovered while testing at connectathon. When testing busy file rename code, the test would fail against bluearc servers. The bluearc guys turned on tracing and determined that it was failing because the SYNCHRONIZE bit wasn't being set on open.

Testing with that bit set seems to fix it against their servers. We'll need to test more extensively, but they claimed that win2k also requires it (there were some comments in their code to that effect).
Comment 1 Jeff Layton 2009-03-04 09:16:57 EST
It turns out that this is actually a bug in BlueArc's stuff. The MS docs explicitly state that SYNCHRONIZE should not be set by clients and should be ignored by servers. I think it really only has meaning in opens on local filesystems.

I've contacted bluearc to let them know that we think this is a bug in their server code.

Note You need to log in before you can comment on or make changes to this bug.