Bug 487222 - X crashes on resume with KMS and desktop effects (compiz) enabled
X crashes on resume with KMS and desktop effects (compiz) enabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 15:57 EST by Samuel Sieb
Modified: 2009-11-09 09:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-09 09:42:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (63.64 KB, text/plain)
2009-02-24 16:19 EST, Samuel Sieb
no flags Details

  None (edit)
Description Samuel Sieb 2009-02-24 15:57:39 EST
When resuming the laptop while desktop effects are enabled, X crashes immediately.  No xorg.conf file.  I will attach the log.

kernel-2.6.27.15-170.2.24.fc10.i686
xorg-x11-drv-ati-6.10.0-2.fc10.i386

Enable desktop effects.
Suspend laptop.
Resume laptop.
X crash.

Program received signal SIGABRT, Aborted.
0x0093a416 in __kernel_vsyscall ()
(gdb) where
#0  0x0093a416 in __kernel_vsyscall ()
#1  0x0034d460 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2  0x0034ee28 in abort () at abort.c:88
#3  0x005d1654 in bufmgr_classic_bo_map (bo_base=0x88f0360, write_enable=1)
    at r300_mem.c:695
#4  0x005f3db8 in dri_bo_map (buf=0x88f0360, write_enable=0 '\0')
    at radeon_dri_bufmgr.c:73
#5  0x005dec6c in r300_teximage_map (image=0x8871ab0, write_enable=0 '\0')
    at r300_tex.c:452
#6  0x005def8d in r300_texsubimage (ctx=0x85a90e8, dims=2, level=0, xoffset=0, 
    yoffset=0, zoffset=0, width=1024, height=768, depth=1, format=32993, 
    type=5121, pixels=0xb3caf008, packing=0x85b4d88, texObj=0x89adc38, 
    texImage=0x8871ab0, compressed=0) at r300_tex.c:696
#7  0x005df11b in r300TexSubImage2D (ctx=0x85a90e8, target=34037, level=0, 
    xoffset=0, yoffset=0, width=1024, height=768, format=32993, type=5121, 
    pixels=0xb3caf008, packing=0x85b4d88, texObj=0x89adc38, texImage=0x8871ab0)
    at r300_tex.c:747
#8  0x0101e6d6 in _mesa_TexSubImage2D (target=34037, level=0, xoffset=0, 
    yoffset=0, width=1024, height=768, format=32993, type=5121, 
    pixels=0xb3caf008) at main/teximage.c:2837
#9  0x002a2fa9 in __glXDRIbindTexImage (baseContext=0x8598c58, buffer=8414, 
    glxPixmap=0x887f8c8) at glxdri.c:551
#10 0x00294c18 in __glXDisp_BindTexImageEXT (cl=0x8576f1c, 
    pc=0x899bcd4 "\232\020\006") at glxcmds.c:1541
#11 0x00293ae7 in __glXDisp_VendorPrivate (cl=0x8576f1c, 
    pc=0x899bcd4 "\232\020\006") at glxcmds.c:2256
#12 0x0029863a in __glXDispatch (client=0x8575d28) at glxext.c:512
#13 0x08085e9f in Dispatch () at dispatch.c:454
#14 0x0806b71d in main (argc=8, argv=0xbf851c14, envp=Cannot access memory at address 0x10cc
) at main.c:441
Comment 1 Samuel Sieb 2009-02-24 16:19:59 EST
Created attachment 333090 [details]
Xorg.0.log
Comment 2 Jérôme Glisse 2009-10-15 10:32:49 EDT
Do you still have this issue with fedora 12 (you can test livecd from http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/) ?
Comment 3 Samuel Sieb 2009-10-20 17:56:18 EDT
I finally rebooted my laptop and the problem still exists.

On resume, the graphical text console comes back with the last messages from suspending, but the system is locked up.
Comment 4 Jérôme Glisse 2009-10-21 11:54:32 EDT
You rebooted with fedora 12 ? If so please attach new dmesg & Xorg.0.log
Comment 5 Samuel Sieb 2009-10-28 17:55:58 EDT
Well, now I don't know what to say...  I tried it again and tried really hard to get it to lock up, but it wouldn't.  Yes, I was using the F12 beta live image.

I very rarely reboot my laptop, but the next time I get a chance, I will try it again.
Comment 6 Samuel Sieb 2009-11-08 22:13:48 EST
I tried again and couldn't hang it, so I guess I must have hit an unlucky random event the first time.  For now I consider this fixed.  I'll see what happens when I upgrade the laptop to F12 after it is released.
Comment 7 Matěj Cepl 2009-11-09 09:42:06 EST
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.