Bug 487226 - [RFE] No Startup Script for RPL boot daemon
[RFE] No Startup Script for RPL boot daemon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpld (Show other bugs)
15
All Linux
low Severity medium
: ---
: ---
Assigned To: Paul P Komkoff Jr
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 16:31 EST by William Makowski
Modified: 2011-11-28 19:23 EST (History)
1 user (show)

See Also:
Fixed In Version: rpld-1.8-0.11.beta1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-28 19:10:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Possible Startup Script for rpld (1.15 KB, text/plain)
2009-02-24 16:31 EST, William Makowski
no flags Details

  None (edit)
Description William Makowski 2009-02-24 16:31:10 EST
Created attachment 333091 [details]
Possible Startup Script for rpld

Description of problem: The package for the RPL boot daemon does not include an init script. It would be preferable to add rpld as a service rather than restart it manually after a reboot. The script would also stop the daemon during a shutdown.

Version-Release number of selected component (if applicable): 1.8-0.4.beta1.fc10

How reproducible: Install rpld

Actual results: Must start RPL manually after a reboot.

Expected results: Use chkconfig to start and stop as a service based on runlevel.

Additional info: I've attached a possible script.  rpld doesn't create a rpld.pid file when it runs.  During start() I added the pidof command to create a pid file so the daemon function in /etc/init.d/functions would check to see if it is running before starting.  There's probably a better or more preferred way of doing this.  Then again, it may not even be that critical.
Comment 1 William Makowski 2009-07-28 07:41:22 EDT
This continues to be an issue in fc11 with package rpld-1.8-0.5-beta1-fc11.
Comment 2 William Makowski 2009-11-22 11:10:13 EST
Still hoping that an init script will be added to this package to automate starting and stopping of RPL.  rpld-1.8-0.6.beta1.fc12.i686 does not include a script.  The one I supplied has been working pretty well since Fedora 10.
Comment 3 William Makowski 2010-08-17 15:07:35 EDT
I changed the bug summary to a RFE.  In fc13 the package version is the same as fc12 (rpld-1.8-0.6.beta1.fc12.i686).  The script I uploaded on 2009-02-24 works with fc13.
Comment 4 William Makowski 2011-03-03 10:34:48 EST
The Version for this request has been updated to 14. The rpld package is still rpld-1.8-0.6.beta1.fc12.i686 in fc14. The attached startup script continues to work with fc14.
Comment 5 Fedora Update System 2011-06-02 11:42:03 EDT
rpld-1.8-0.8.beta1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rpld-1.8-0.8.beta1.fc14
Comment 6 Fedora Update System 2011-06-02 11:42:14 EDT
rpld-1.8-0.8.beta1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rpld-1.8-0.8.beta1.fc15
Comment 7 Fedora Update System 2011-06-02 11:42:21 EDT
rpld-1.8-0.8.beta1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/rpld-1.8-0.8.beta1.fc13
Comment 8 Fedora Update System 2011-06-03 01:31:21 EDT
Package rpld-1.8-0.8.beta1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpld-1.8-0.8.beta1.fc13'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/rpld-1.8-0.8.beta1.fc13
then log in and leave karma (feedback).
Comment 9 William Makowski 2011-06-05 13:09:11 EDT
Tested install on Fedora 13, 14, and 15. The init script is okay, but rpld is not added as a service so it can't be managed using chkconfig. There needs to be a post install step in the spec file using /sbin/chkconfig --add rpld.  The startup script I supplied will automatically turn on run levels 345.  It is probably best to turn that off and leave it up to the end user.
Comment 10 Fedora Update System 2011-07-05 09:28:42 EDT
rpld-1.8-0.10.beta1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rpld-1.8-0.10.beta1.fc15
Comment 11 Fedora Update System 2011-07-05 09:28:52 EDT
rpld-1.8-0.10.beta1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rpld-1.8-0.10.beta1.fc14
Comment 12 William Makowski 2011-10-04 12:39:21 EDT
My apologies for taking so long to get back on testing the latest updates. It looks like I may be one of the few people that still use this package.

These are very close, but there are two items that I feel need to be changed. First in rpld.specs a line needs to be added to %preun to delete the rpld service if someone uninstalls rpld.

%preun
if [ "$1" = 0 ]; then
    /sbin/service %{name} stop >/dev/null 2>&1
    /sbin/chkconfig --del %{name}
fi

Secondly, the rpld startup script in /etc/init.d should not automatically turn on run levels 345 upon installation.  The user will need to create a /etc/rpld.conf configuration file before starting the service.  Once that is complete they can turn on the service using chkconfig for the desired runlevels.  The line to change in /etc/init.d/rpld is...

< # chkconfig:    345 80 20
> # chkconfig:    - 80 20

These two changes should make the package ready to move from testing to stable. I'm also updating the Fedora version for this request from 14 to 15.
Comment 13 Fedora Update System 2011-11-03 11:00:38 EDT
rpld-1.8-0.11.beta1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rpld-1.8-0.11.beta1.fc16
Comment 14 Fedora Update System 2011-11-03 11:00:48 EDT
rpld-1.8-0.11.beta1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rpld-1.8-0.11.beta1.fc15
Comment 15 Fedora Update System 2011-11-03 11:00:58 EDT
rpld-1.8-0.11.beta1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/rpld-1.8-0.11.beta1.fc14
Comment 16 Fedora Update System 2011-11-28 19:10:17 EST
rpld-1.8-0.11.beta1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2011-11-28 19:18:14 EST
rpld-1.8-0.11.beta1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2011-11-28 19:23:30 EST
rpld-1.8-0.11.beta1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.