Bug 48724 - Wrong place of several Mailman files
Wrong place of several Mailman files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-11 05:12 EDT by Jos Vos
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-14 15:51:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2001-07-11 05:12:48 EDT
The mailman 2.0.5-2 package still contains large sets of files being
installed at the wrong place, IMHO.

Files from /var/mailman/{Mailman,cgi-bin,bin} should be in /usr
(/usr/share?).

The /var/mailman/logs directory should be in /var/log (symlink
/var/mailman/logs -> /var/log/mailman ?)

The /var/mailman/qfiles directory should be in /var/spool (symlink
/var/mailman/qfiles -> /var/spool/mailman ?).

And maybe more...

Maybe I'll try to make an adapted spec file, if appreciated.
Comment 1 R P Herrold 2001-11-15 10:50:14 EST
Logrotate issues, too ...

... Additionally, Mailman log files grow without limit 

It would seem that -- a postinstall script to effect relocation of existing
/var/mailman/logs/ to /var/log/mailman (to support upgrades)

removal of content at the former /var/mailman/logs (again to support upgrades)

a link    ln -s /var/log/mailman /var/mailman/logs

and addition of a /etc/logrotate.d/mailman file 

are in order.  I'll make sure I am up to date against Raw Hide and submit a
specfile patch.

Comment 2 R P Herrold 2001-11-15 10:52:37 EST
... ummm  RH 7.2 released is same as Raw Hide ---
Comment 3 Jay Turner 2002-02-13 15:41:57 EST
What's the status of this?
Comment 4 Jos Vos 2002-02-13 15:48:56 EST
Nothing changed, all the issues are still there...
Comment 5 John Dennis 2003-03-13 16:31:43 EST
I took ownership of mailman recently. Its been upgraded to the current release
of 2.1.1. I did not change the file locations, I believe the log rotate
functionality is in place. What is the reasoning behind the assertion the file
locations are wrong? If you make a good case for why they are wrong I'll fix it,
but be aware the upstream sources place some restrictions on installation
directories and I'd like to avoid having to change the upstream sources to
relocate files.

P.S.: I'd like to close this bug out.
Comment 6 Jos Vos 2003-03-13 17:02:49 EST
As I said in my original bug report, I believe that different kind of files have
to be in different subtrees (like specified in the filesystem hierarchy
standard). Like with http, where /etc/httpd contains various symlinks to places
more logical for the httpd subtrees. So, using symlinks this can be done without
changing the upstream package.
Comment 7 John Dennis 2005-02-14 15:51:40 EST
The current mailman RPM's adhere to FHS.

Note You need to log in before you can comment on or make changes to this bug.