Bug 487245 - network service disabled even if NetworkManager isn't installed
network service disabled even if NetworkManager isn't installed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 18:37 EST by Joshua Baker-LePain
Modified: 2009-02-24 21:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 21:46:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Baker-LePain 2009-02-24 18:37:18 EST
Description of problem:
My standard kickstart file excludes NetworkManager in the %packages section (these are cluster nodes and NM really isn't needed).  After doing a kickstart network install, the node reboots and comes up without networking due to the fact that the "network" service is disabled.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.  Kickstart, exluding NetworkManager
2.  Reboot.
3.
  
Actual results:
A system with its fingers stuck in its ears.

Expected results:
If anaconda sees that NetworkManager isn't installed, the network service should be enabled.

Additional info:
Comment 1 Jeremy Katz 2009-02-24 21:46:35 EST
NetworkManager handles the networking by default in Fedora.  If you're not using it, you need to enable the network service with a services line.  This is similar to if you forcibly didn't install any other core part of Fedora

Having the installer know about defaults like this doesn't scale as you can use a single installer image with a wide variety of package repos (which may have different policies about network vs NetworkManager and similar for any other services)

Note You need to log in before you can comment on or make changes to this bug.