Bug 487273 - Nautilus crashes when writing to a Windows share
Nautilus crashes when writing to a Windows share
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 04:02 EST by An. N
Modified: 2015-03-03 17:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 04:25:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description An. N 2009-02-25 04:02:10 EST
Description of problem:
Nautilus crashes when writing to a Windows share. No warning message, no error message, just goes away, then restarts after a short while. It seems that the files get written correctly though.

Maybe this should be assigned to a different component, since there is no way to find out why it's crashing.

Version-Release number of selected component (if applicable):
nautilus-2.24.2-1.fc10.x86_64
gvfs-1.0.3-4.fc10.x86_64
gvfs-smb-1.0.3-4.fc10.x86_64
samba-3.2.8-0.26.fc10.x86_64
gnome-vfs2-smb-2.24.0-3.fc10.x86_64
libsmbclient-3.2.5-0.23.fc10.x86_64
samba-client-3.2.8-0.26.fc10.x86_64

How reproducible:
Most of the times, but not always (same share)

Steps to Reproduce:
1. Open a Windows share in Nautilus
2. Write files
3.
  
Actual results:
Nautilus crashes, X lags for some 10 seconds, mayhem.
Files get written

Expected results:
Files get written, nothing crashes, everybody's happy

Additional info:
Comment 1 R Dhushyanth 2009-02-25 05:09:30 EST
Thank you for the bug report. Without a stack trace from the crash it is
impossible to determine what caused the crash. Please see
http://fedoraproject.org/wiki/StackTraces for more information about
getting a useful stack trace.
Comment 2 An. N 2009-02-26 08:23:57 EST
There seems to be no core dump.

Also, I noticed that some files don't get written to the remote share after all and it tends to happen on move.
Comment 3 An. N 2009-02-26 08:35:11 EST
I tried to obtain a nautilus log but there's nothing unusal there - just "files changed" messages.

and this:
0x25e94d0 2009/02/26 14:30:40.6456 (GLog): Unable to add monitor: Not supported
Comment 4 Adam Williamson 2009-02-26 15:56:45 EST
If you run nautilus from a console and then reproduce the bug, do you get any interesting information at the console?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 An. N 2009-02-27 08:23:25 EST
(nautilus:6275): GLib-CRITICAL **: g_strsplit: assertion `string != NULL' failed

(nautilus:6275): GLib-CRITICAL **: g_strv_length: assertion `str_array != NULL' failed
Comment 6 Adam Williamson 2009-02-27 18:52:21 EST
I doubt that's related to the crash (I'm guessing you'd probably see those messages if you just ran Nautilus at a console and did something else). Hmm, sorry, not sure about this one :\

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 An. N 2009-02-28 04:30:29 EST
In this case those 2 messages pop up and then nautilus crashes instantly. Might be related or not I guess.

Any other methods to debug?
Comment 8 An. N 2009-03-02 04:25:47 EST
If found out that this is caused by an external addon to Nautilus and most likely is not a problem with Nautilus.

Note You need to log in before you can comment on or make changes to this bug.