Bug 487285 - xorg 1.5.3-13.fc10 segv's upon startup (regression)
xorg 1.5.3-13.fc10 segv's upon startup (regression)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 05:38 EST by Wolfgang Rupprecht
Modified: 2009-10-16 07:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-16 07:27:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (28.42 KB, text/plain)
2009-02-25 05:38 EST, Wolfgang Rupprecht
no flags Details
xorg conf file (267 bytes, text/plain)
2009-02-25 05:40 EST, Wolfgang Rupprecht
no flags Details
/var/log/messages snippet from booting. (48.22 KB, text/plain)
2009-02-25 16:12 EST, Wolfgang Rupprecht
no flags Details
Hugh's Xorg.0.log for 1.5.3-13.fc10 (fails) (31.12 KB, text/plain)
2009-02-27 20:14 EST, D. Hugh Redelmeier
no flags Details
Hugh's Xorg.0.log for 1.5.3-6.fc10 (works) (101.01 KB, text/plain)
2009-02-27 20:15 EST, D. Hugh Redelmeier
no flags Details
Xorg log file - xorg-x11-server-Xorg-1.5.3-15.fc10.x86_64 (28.42 KB, text/plain)
2009-03-14 12:11 EDT, Wolfgang Rupprecht
no flags Details

  None (edit)
Description Wolfgang Rupprecht 2009-02-25 05:38:20 EST
Created attachment 333146 [details]
Xorg log file

Description of problem:
xorg segv's upon startup.

Version-Release number of selected component (if applicable):
 xorg-x11-server-Xorg.x86_64 0:1.5.3-13.fc10                                   
 xorg-x11-server-common.x86_64 0:1.5.3-13.fc10                                 

How reproducible:
every time

Steps to Reproduce:
1. reboot
2. watch gdm flash the screen as X repeatedly dies.
3.
  
Actual results:
X dies

Expected results:
X doesn't die

Additional info:
This problem was introduced with the latest "yum update" which included the above pkgs.  The previous version was fine.
Comment 1 Wolfgang Rupprecht 2009-02-25 05:40:17 EST
Created attachment 333147 [details]
xorg conf file
Comment 2 Matěj Cepl 2009-02-25 09:20:35 EST
Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e7b66]
1: /usr/bin/Xorg(xf86SigHandler+0x39) [0x47d659]
2: /lib64/libc.so.6 [0x3a08432f90]
3: /usr/bin/Xorg(xf86InitViewport+0x4d) [0x46d1dd]
4: /usr/bin/Xorg(InitOutput+0xe03) [0x463963]
5: /usr/bin/Xorg(main+0x286) [0x42cb46]
6: /lib64/libc.so.6(__libc_start_main+0xe6) [0x3a0841e576]
7: /usr/bin/Xorg [0x42c0f9]
Comment 3 Wolfgang Rupprecht 2009-02-25 16:12:38 EST
Created attachment 333233 [details]
/var/log/messages snippet from booting.

There is a bit of funniness with the aperture hole at bootup.  It may be related (and perhaps even what tickles this bug).  The motherboard is an Asus m3a78t with integrated graphics and > 4gigs dram.
Comment 4 D. Hugh Redelmeier 2009-02-27 20:11:39 EST
I too experience this problem.  See this thread: https://www.redhat.com/archives/fedora-list

Don't work:
 xorg-x11-server-Xorg.x86_64 0:1.5.3-13.fc10                                   
 xorg-x11-server-common.x86_64 0:1.5.3-13.fc10                                 

Work: 1.5.3-6.fc10 versions.

My system is an HP Pavilion A6245n
- C2Q6600 CPU
- 6G RAM
- Asus Asus EAH3650 Silent Magic video card
- Dell LCD (2560 x 1600 pixels)

All Fedora 10 updates are in place EXCEPT that I'm using xorg-x11-drv-ati-6.9.0-63.fc10.x86_64 due to https://bugzilla.redhat.com/show_bug.cgi?id=484636

There is some message that flashes when I boot (very early) that might be related to 4G and apertures.  It does not show up in dmesg output.  This is not new.

dmesg output isn't changed by the update.

When booting with the "bad" server packages, /var/log/message shows a lot of respawning of the X server.  There are a bunch of /var/log/Xorg.?.log files created.

Diffing Xorg.0.log files from bad and good runs, there are a couple of things I noted.

- Bad uses VT 7 whereas good uses VT 1.

-(II) RADEON(0): Using exact sizes for initial modes
-(EE) RADEON(0): Output DVI-0 enabled but has no modes
+(II) RADEON(0): Using fuzzy aspect match for initial modes
+(II) RADEON(0): Output DVI-0 using initial mode 2560x1600

This last difference seems to be the root of the problem.


If I had to guess which change caused the problem, I'd pick this one:

    * Mon Dec 22 2008 Adam Jackson <ajax@redhat.com> 1.5.3-8
    - xserver-1.5.3-aspect-me-harder.patch: Fix mode selection when only one
      monitor is present and it doesn't claim a preferred mode.
    - xserver-1.5.0-bad-fbdev-thats-mine.patch: Do the same for sbus that we
      do for pci.
    - xserver-1.5.0-hide-cursor.patch: Backport fixes to unhide logic from master.
Comment 5 D. Hugh Redelmeier 2009-02-27 20:14:24 EST
Created attachment 333570 [details]
Hugh's Xorg.0.log for 1.5.3-13.fc10 (fails)
Comment 6 D. Hugh Redelmeier 2009-02-27 20:15:57 EST
Created attachment 333571 [details]
Hugh's Xorg.0.log for 1.5.3-6.fc10 (works)
Comment 7 Wolfgang Rupprecht 2009-02-27 20:26:02 EST
I find it interesting that Hugh and I both have very similar 2560x1600 pixel monitors.  The modes these monitors present are somewhat unusual in that they are all marked as "Supported additional Video Mode". Might the lack of normal VESA modes be throwing the new mode-choosing code for a loop?
Comment 8 D. Hugh Redelmeier 2009-02-28 03:00:58 EST
In #4 I had the wrong link to the thread.  Here is the right link.
https://www.redhat.com/archives/fedora-list/2009-February/msg02797.html
Comment 9 Wolfgang Rupprecht 2009-03-14 12:11:18 EDT
Created attachment 335212 [details]
Xorg log file - xorg-x11-server-Xorg-1.5.3-15.fc10.x86_64

The new update from this morning, xorg-x11-server-Xorg-1.5.3-15.fc10.x86_64 is also broken.

Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e7c96]
1: /usr/bin/Xorg(xf86SigHandler+0x39) [0x47a6a9]
2: /lib64/libc.so.6 [0x3a08432f90]
3: /usr/bin/Xorg(xf86InitViewport+0x4d) [0x4766bd]
4: /usr/bin/Xorg(InitOutput+0xe03) [0x463993]
5: /usr/bin/Xorg(main+0x286) [0x42cb76]
6: /lib64/libc.so.6(__libc_start_main+0xe6) [0x3a0841e576]
7: /usr/bin/Xorg [0x42c129]

Fatal server error:
Caught signal 11.  Server aborting
Comment 10 seventhguardian 2009-10-16 04:09:56 EDT
Does this still happen with versions 1.6.* or 1.7.*?
Comment 11 Wolfgang Rupprecht 2009-10-16 04:17:38 EDT
No, I haven't seen this bug in many months.  In any case the current F11 version doesn't crash.

X.Org X Server 1.6.3.901 (1.6.4 RC 1)
Release Date: 2009-8-25
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-164.el5 x86_64 
Current Operating System: Linux arbol.wsrcc.com 2.6.30.8-64.fc11.x86_64 #1 SMP Fri Sep 25 04:43:32 EDT 2009 x86_64
Kernel command line: ro root=/dev/mapper/vg_arbol-lv_root
Build Date: 09 September 2009  11:26:05AM
Build ID: xorg-x11-server 1.6.4-0.1.fc11
Comment 12 seventhguardian 2009-10-16 04:31:09 EDT
Then the bug should be closed, right?
Comment 13 Wolfgang Rupprecht 2009-10-16 04:35:45 EDT
Yes, feel free to close.  thanks!
Comment 14 seventhguardian 2009-10-16 04:45:08 EDT
Only the reporter and the admins can close it, that's why I asked you to do it ;)
Comment 15 Wolfgang Rupprecht 2009-10-16 07:27:21 EDT
I've never closed one before.  Someone else has always done it. 

The closest sounding choice to "fixed" seems to be "currentrelease".  Hope that is the right choice.
Comment 16 seventhguardian 2009-10-16 07:54:20 EDT
(In reply to comment #15)
> The closest sounding choice to "fixed" seems to be "currentrelease".  Hope that
> is the right choice.
  
Seems to be :) Thanks!

Note You need to log in before you can comment on or make changes to this bug.