Bug 487286 - Ring queue fails with resource-limit-exceeded exception
Ring queue fails with resource-limit-exceeded exception
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
urgent Severity medium
: 1.1.1
: ---
Assigned To: Gordon Sim
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 05:50 EST by Gordon Sim
Modified: 2015-11-15 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 12:16:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test example (4.46 KB, application/x-compressed-tar)
2009-02-25 05:50 EST, Gordon Sim
no flags Details

  None (edit)
Description Gordon Sim 2009-02-25 05:50:51 EST
Created attachment 333148 [details]
Test example

Ring queue (in non-strict mode) should always replace oldest messages to make way for new messages so the error observed with attached test case should never occur. 

To reproduce using attached test case (from William Henry):
1. run declare_queues
2. start topic_listener 
3. in separate terminal run topic_publisher 6000
Comment 1 Gordon Sim 2009-02-25 06:03:00 EST
Fixed in r747744.
Comment 3 Frantisek Reznicek 2009-03-26 12:22:07 EDT
I was not able to reproduce the issue on any packages before r747744 and also svn checkout r747740.

The issue is not visible anymore, validated on RHEL 4.7 / 5.2 / 5.3, i386 / x86_64 on packages:
python-qpid-0.5.752581-1.el5
qpidc-0.5.752581-1.el5
qpidc-devel-0.5.752581-1.el5
qpidc-perftest-0.5.752581-1.el5
qpidc-rdma-0.5.752581-1.el5
qpidc-ssl-0.5.752581-1.el5
qpidd-0.5.752581-1.el5
qpidd-acl-0.5.752581-1.el5
qpidd-cluster-0.5.752581-1.el5
qpidd-devel-0.5.752581-1.el5
qpidd-rdma-0.5.752581-1.el5
qpidd-ssl-0.5.752581-1.el5
qpidd-xml-0.5.752581-1.el5
qpid-java-client-0.5.751061-1.el5
qpid-java-common-0.5.751061-1.el5
rhm-0.5.3153-1.el5
rhm-docs-0.5.756148-1.el5


->VERIFIED
Comment 5 errata-xmlrpc 2009-04-21 12:16:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0434.html

Note You need to log in before you can comment on or make changes to this bug.