Bug 487344 - printer-applet is started even if no printers are configured
printer-applet is started even if no printers are configured
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 10:14 EST by Piotr Piotrowski
Modified: 2009-03-18 13:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 11:39:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piotr Piotrowski 2009-02-25 10:14:37 EST
User-Agent:       Mozilla/5.0 (compatible; Konqueror/4.2; Linux) KHTML/4.2.0 (like Gecko) Fedora/4.2.0-15.fc10

I have no printer, but printer-applet is started anyway eating up memory (together with some other autostarted apps I do not use). The applet uses over 30 MB (RES column in top on x86_64).

Please disable the autostart, unless it is crucial for the applet to be running. You might consider adding

X-KDE-autostart-condition=printer-appletrc:General:Autostart:false

to /usr/share/autostart/printer-applet.desktop, so the autostart is configurable and not global.


Reproducible: Always
Comment 1 Rex Dieter 2009-02-25 10:25:34 EST
The "proper" fix would be to start on demand when printing happens, but until then, hacking around (as suggested) is likely frought with peril for most folk.
Comment 2 Rex Dieter 2009-03-18 09:36:31 EDT
*shrug*, making it configurable (via X-KDE-autostart-condition) is acceptable to me, I guess.
Comment 3 Ngo Than 2009-03-18 11:39:18 EDT
most users have printers nowadays, so disable it by default is not good. If you don't have printer you can still remove the kdeutils-printer-applet subpackage.
Comment 4 Kevin Kofler 2009-03-18 11:46:08 EDT
Except that it's required by kdeutils for upgrade path reasons.
Comment 5 Piotr Piotrowski 2009-03-18 12:49:38 EDT
I do agree that the proper fix would be to start on demand. However, making it configurable with autostart *on by default* would, in my opinion, also be acceptable. This would not break anything and people get to choose what is running on their system.

For the record, trying to uninstall it was the first thing I did but the dependencies made me look for other fix/hack.

The problem is that it eats quite a lot of RAM and is not the only such app wasting my memory - this might be called a general trend. Where are the times 128 MB was enough for Red Hat Linux. ;-P
Comment 6 Rex Dieter 2009-03-18 13:07:06 EDT
I don't see any generation or use of an printer-appletrc anywhere.  Am I missing something?  

If that's missing, then hacking it in fedora is a no-go, and should be taken upstream to implement fully/properly.

Note You need to log in before you can comment on or make changes to this bug.