This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 487348 - Undefined symbol in module load.
Undefined symbol in module load.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PyQwt (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Tadej Janež
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 10:40 EST by Ian Thompson
Modified: 2009-03-27 10:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.1.0-4.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-27 10:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Thompson 2009-02-25 10:40:50 EST
Description of problem:
Running any of the demo programs produces the error ...

ImportError: /usr/lib/python2.5/site-packages/PyQt4/Qwt5/Qwt.so: 
undefined symbol: _ZN16QwtPlotMagnifier16widgetWheelEventEP11QWheelEvent

Version-Release number of selected component (if applicable):

Versions of packages on the machine ...
PyQt4 - 4.4.4-1.fc10
PyQwt - 5.1.0-3.fc10
Python - 2.5.2-1.fc10
qt   - 1:4.4.3-10.fc10
qwt  - 5.1.1-2.fc10

How reproducible:
Everytime

Steps to Reproduce:
1. python
2. import PyQt4.Qwt5
3. error
  
Actual results:


Expected results:


Additional info:
Comment 1 Fedora Update System 2009-03-06 04:40:05 EST
PyQwt-5.1.0-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/PyQwt-5.1.0-4.fc10
Comment 2 Tadej Janež 2009-03-07 09:38:31 EST
Thanks for reporting the problem.

I issued a rebuild of PyQwt for new qwt and it seems to be working again.
The update should appear in updates-testing repository within a few days.
Please test the new version of the package.
Comment 3 Fedora Update System 2009-03-09 19:04:55 EDT
PyQwt-5.1.0-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PyQwt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2538
Comment 4 Fedora Update System 2009-03-27 10:48:15 EDT
PyQwt-5.1.0-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.