Bug 487357 - Install hangs at autopartitionexecute
Install hangs at autopartitionexecute
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Blocker/F11FinalBlocker F11Beta/F11BetaBlocker
  Show dependency treegraph
 
Reported: 2009-02-25 11:32 EST by Orion Poplawski
Modified: 2009-03-14 10:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-14 10:55:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vt1 (9.01 KB, image/png)
2009-02-26 11:15 EST, Orion Poplawski
no flags Details
vt2 - top (24.77 KB, image/png)
2009-02-26 11:15 EST, Orion Poplawski
no flags Details
vt3 (16.54 KB, image/png)
2009-02-26 11:16 EST, Orion Poplawski
no flags Details
vt4 (23.29 KB, image/png)
2009-02-26 11:16 EST, Orion Poplawski
no flags Details
vt5 (3.58 KB, image/png)
2009-02-26 11:18 EST, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2009-02-25 11:32:27 EST
Description of problem:

Installing 20090225 rawhide x86_64 as xen guest.  PXE/kickstart install.

Install gets to:

moving (1) to step autopartitionexecute

and hangs.  top shows 2 anaconda processes using cpu (~70% and ~15% each).

VNC display is all black.

Version-Release number of selected component (if applicable):
11.5.0.23

How reproducible:
2 for 2 now
Comment 1 Chris Lumens 2009-02-25 12:53:20 EST
Is it genuinely hung, or is it just very, very slow?  How long are you waiting before deciding it's hung up?  The new pyparted is fairly slow and could be what you are seeing.  This is the right spot, at least.
Comment 2 Orion Poplawski 2009-02-25 17:58:39 EST
I gave up after an hour...
Comment 3 Chris Lumens 2009-02-26 10:59:52 EST
That definitely doesn't sound like pyparted slowness, then.  Is the machine locked up?  Can you switch to tty3 and tty4 and see if there's anything going on?  I'm especially interested if there are any kernel error messages displayed.
Comment 4 Orion Poplawski 2009-02-26 11:15:06 EST
Created attachment 333346 [details]
vt1
Comment 5 Orion Poplawski 2009-02-26 11:15:47 EST
Created attachment 333347 [details]
vt2 - top
Comment 6 Orion Poplawski 2009-02-26 11:16:20 EST
Created attachment 333349 [details]
vt3
Comment 7 Orion Poplawski 2009-02-26 11:16:59 EST
Created attachment 333350 [details]
vt4
Comment 8 Orion Poplawski 2009-02-26 11:18:27 EST
Created attachment 333351 [details]
vt5
Comment 9 Orion Poplawski 2009-02-26 11:19:57 EST
Machine appears to be running fine.  No particular error messages.  Anaconda is just spinning.
Comment 10 Orion Poplawski 2009-02-27 16:00:52 EST
Today I get a traceback:

File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 27 in <module>
  from cachedlist import CachedList

Not sure if this is a pyparted issue, or anaconda not providing cachedlist...
Comment 11 Julian Sikorski 2009-02-27 19:38:29 EST
I got the same issue as mentioned in comment #10 while trying to install x86_64 rawhide kvm guest.
Comment 12 David Cantrell 2009-02-27 19:50:34 EST
(In reply to comment #10)
> Today I get a traceback:
> 
> File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 27 in <module>
>   from cachedlist import CachedList
> 
> Not sure if this is a pyparted issue, or anaconda not providing cachedlist...

This is pyparted and will be fixed in pyparted-2.0.3-1.fc11.
Comment 13 Orion Poplawski 2009-03-03 11:13:41 EST
Back to spinning again today.  How else to debug this?
Comment 14 Orion Poplawski 2009-03-03 12:05:56 EST
Looks like on i386 it generally stops a step earlier:

no /tmp/fcpconfig; not configuring zfcp

strace shows anaconda spinning on stdin:

ppoll([{fd=0, events=POLLIN|POLLPRI|POLLERR|POLLHUP|0x400}], 1, {#, #}, ~[HUP INT TERM RTMIN], 8) = -1 EINVAL (Invalid argument)
recvfrom(0, 0xbf8ec2cc, 8988, 64, 0xbf8ec150, 0xbf8ec15c) = -1 EAGAIN (Resource temporarily unavailable)

ls -l /proc/1165/fd
lrwx------- 1 root root 64 Mar 3 09:36 0 -> socket:[5896]
Comment 15 Julian Sikorski 2009-03-03 12:12:25 EST
This could be xen- or pxe- specific, since with kvm I'm able to reach an attempt to fetch repodata, where I'm getting bitten by #487925.
Comment 16 Orion Poplawski 2009-03-14 10:55:42 EDT
Appears to be fixed in today's rawhide.

Note You need to log in before you can comment on or make changes to this bug.