Bug 48741 - handling interface configurations in sysconfig/networking/
Summary: handling interface configurations in sysconfig/networking/
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-11 10:11 UTC by Pekka Savola
Modified: 2014-03-17 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-11 18:59:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2001-07-11 10:11:29 UTC
initscripts 6.02.

New initscripts move ifcfg-lo to /etc/sysconfig/networking/.

However, ifup does not look for it, with command 'ifup lo', from there; if
no profiles
have been configured, it appears to go through:

1) networking/default/lo
2) networking/default/ifcfg-lo
3) network-scripts/ifcfg-lo

This appears rather controversial.  Should ifcfg-lo be moved somewhere
else, and/or ifup changed?  (devices subdirectory, for instance, appears to
be unused for now).

Also, in ifup I'd replace:

[ -f "${CONFIG}" ] || \
    CONFIG=../networking/`current_profile`/${1}
[ -f "${CONFIG}" ] || \
    CONFIG=../networking/`current_profile`/"ifcfg-${1}"
[ -f "${CONFIG}" ] || \
    CONFIG="ifcfg-${1}"

( perhaps also the error messages too, with s/ifup/$0/ )

with function "need_config", and the same job would be defined in
network-functions.  This is because this behaviour might be needed in other
ifup-*, ifdown-* or similar scripts too (most should be run from ifup
passing ${CONFIG} so this might not be absolutely necessary but it might
make the code nicer)

Comment 1 Bill Nottingham 2001-07-11 18:59:15 UTC
Um, look at the makefile; we make a symlink to /etc/sysconfig/networking/ifcfg-lo
from /etc/sysconfig/network-scripts. So it all works OK.

What I *think* happens is that when neat runs, it puts whatever is in
/etc/sysconfig/networking (shared state) into the specific profile configuration.

Comment 2 Bill Nottingham 2001-07-11 19:04:10 UTC
The suggestion for moving the config stuff to network-functions will be in 6.03-1.

Comment 3 Pekka Savola 2001-07-11 19:18:13 UTC
Oh sorry, ifcfg-lo is located in both according to .spec file.  I just noticed the mv command when make whirred by and noticed
ifcfg-lo.rpmsave being created and jumped to conclusions.

I have not heard of this 'neat' before.  However, at this point it seems like ifcfg-lo is 
setting bad example because the primary location where it's located isn't used yet 
(perhaps it should networking/ should be the last backup).

Dunno how temporary these are.

Also, now I am not sure which the proper place to look for 
the configuration files as currently it's being pulled from the legacy location.


Comment 4 Bill Nottingham 2001-07-11 19:33:26 UTC
neat - coming in a redhat-config-network package to a beta near you soon. :)


Note You need to log in before you can comment on or make changes to this bug.