Bug 487419 - non-portable redirect (&>) used in /etc/profile causes spurious ksh login output
non-portable redirect (&>) used in /etc/profile causes spurious ksh login output
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 16:27 EST by Jim Helm
Modified: 2009-02-27 22:29 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.18-3.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 10:34:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Helm 2009-02-25 16:27:35 EST
Description of problem:

"&>" construct used by bash is not portable to ksh.  Login shells under ksh output one "[n]  <pid>" line per file under /etc/profile.d.  Files are still sourced, but it makes ksh logins ugly and causes confusion about where the background jobs are coming from.

Simple fix is just to use the longer and more portable ">/dev/null 2>&1" construct instead.

Version-Release number of selected component (if applicable):


How reproducible:

install ksh and use as login shell.

Steps to Reproduce:
1.
2.
3.
  
Actual results:



Expected results:


Additional info:
Comment 1 Jim Helm 2009-02-25 16:31:53 EST
I meant to add... it's not really a bug with ksh, but the "setup" package that profiles the file isn't listed in the component dropdown.
Comment 2 Michal Hlavinka 2009-02-26 05:49:10 EST
I can confirm, this is reproducible for me, but since this is not a 'ksh' bug, changing component to 'setup'
Comment 3 Ondrej Vasik 2009-02-26 07:11:13 EST
Thanks for report, fixed in Rawhide, setup-2.8.1-1.fc11.
Comment 4 Fedora Update System 2009-02-26 07:22:27 EST
setup-2.7.4-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/setup-2.7.4-4.fc10
Comment 5 Fedora Update System 2009-02-26 07:38:03 EST
setup-2.6.18-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/setup-2.6.18-3.fc9
Comment 6 Fedora Update System 2009-02-26 10:34:06 EST
setup-2.7.4-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-02-27 22:29:35 EST
setup-2.6.18-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.