Bug 48742 - tmpwatch error
tmpwatch error
Status: CLOSED DUPLICATE of bug 47784
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-11 06:53 EDT by Justin Albstmeijer
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-19 11:06:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Replacement /etc/cron.daily/tmpwatch (198 bytes, text/plain)
2001-07-19 10:52 EDT, Need Real Name
no flags Details
Replacement /etc/cron.daily/tmpwatch (fixed) (203 bytes, text/plain)
2001-07-19 11:05 EDT, Need Real Name
no flags Details

  None (edit)
Description Justin Albstmeijer 2001-07-11 06:53:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010701

Description of problem:
I get "error: lstat() of directory /var/cache/man/X11R6/cat? failed: No
such file or directory" when running /etc/cron.daily/tmpwatch.
This problem stated after upgrading to man-1.5i2-0.7x

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh man-1.5i2-0.7x.i386.rpm
2. /etc/cron.daily/tmpwatch

	

Actual Results:  error: lstat() of directory /var/cache/man/X11R6/cat?
failed: No such file or directory

Expected Results:  No error

Additional info:
Comment 1 Need Real Name 2001-07-19 10:52:44 EDT
Created attachment 24127 [details]
Replacement /etc/cron.daily/tmpwatch
Comment 2 Need Real Name 2001-07-19 11:05:47 EDT
Created attachment 24130 [details]
Replacement /etc/cron.daily/tmpwatch (fixed)
Comment 3 Need Real Name 2001-07-19 11:06:23 EDT
The problem is caused by an attempt to use the ? wildcard to match 
directories that don't exist.  (When this happens, the question mark is left 
in the parameter unchanged.)  In this case, the check for the existence of /
var/cache/man is insufficient (on my machine, that directory only contains 
the whatis file).

The second attachment is a replacement /etc/cron.daily/tmpwatch.  It 
solves the problem by filtering out the entries that contain a ?.
The attachment prior to that is a buggy, older version.  Whoops, sorry. ^_^;
Comment 4 Preston Brown 2001-08-06 12:14:26 EDT

*** This bug has been marked as a duplicate of 47784 ***

Note You need to log in before you can comment on or make changes to this bug.