Bug 487430 - F-10 mock cannot build rawhide packages: 4.5 doesn't match environment version 4.7
F-10 mock cannot build rawhide packages: 4.5 doesn't match environment versio...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 17:45 EST by Warren Togami
Modified: 2009-10-26 03:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 03:43:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-02-25 17:45:37 EST
[root@delphi ~]# cat /etc/fedora-release; rpm -q rpm
Fedora release 10 (Cambridge)
rpm-4.6.0-1.fc10.x86_64
mock-0.9.14-1.fc10.noarch

 # /usr/bin/yum --installroot /var/lib/mock/fedora-rawhide-x86_64/root/  resolvedep  ccache  'xulrunner-devel-unstable'
rpmdb: Program version 4.5 doesn't match environment version 4.7
Comment 1 Andrew Overholt 2009-03-03 14:55:22 EST
I'm seeing this as well.  Is there a workaround?
Comment 2 Andrew Overholt 2009-03-05 10:52:52 EST
I was having the issue due to the fact that I was stupidly running mock as root.  Running as a regular user (in the mock group, of course) works fine.  I also rm -rf'd the __db* files in my chroot just to be safe.
Comment 3 Panu Matilainen 2009-03-18 09:29:25 EDT
Warren, are you running mock as root (see comment #2)?

Mock should probably be hacked to use private locking to avoid these but that's another story...
Comment 4 Bug Zapper 2009-06-09 07:39:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Panu Matilainen 2009-07-14 05:01:17 EDT
Running mock as a regular user works for me... Related to bugs 455836, 507309 and a pile of others through various interactions with Berkeley DB.
Comment 6 Pierre Ossman 2009-08-12 04:50:36 EDT
In the interest of getting this working, can't you add this to Root::build():

            # nuke any rpmdb tmp files
            for tmp in glob.glob(self.makeChrootPath('var/lib/rpm/__db*')):
                os.unlink(tmp)

or something similar?
Comment 7 Pierre Ossman 2009-09-10 04:50:40 EDT
Ping!

It seems I cannot reopen the bug to make sure it doesn't get overlooked. :/
Comment 8 Panu Matilainen 2009-10-26 03:43:40 EDT
This shouldn't be an issue starting with rpm >= 4.7.1-3 (available to F11 and newer) as rpm removes the environment on chrooted operations. If you want something fixed in mock, open a bug against mock, not rpm.

Note You need to log in before you can comment on or make changes to this bug.