Bug 487487 - Kernel Update breaks Firefox flash sound on Creative XFi
Kernel Update breaks Firefox flash sound on Creative XFi
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 03:43 EST by Matthew
Modified: 2009-03-09 14:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 14:05:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew 2009-02-26 03:43:48 EST
Description of problem:
Firefox sound through flash won't work on latest kernel.
Sound is through Creative's driver:
XFiDrv_Linux_Public_US_1.00


Version-Release number of selected component (if applicable):
2.6.27.15-170.2.24.fc10.x86_64

How reproducible:
Always. Youtube, or any other video site.


Steps to Reproduce:
1. Watch flash video
2.
3.
  
Actual results:
I get the error (partial below), over and over again when starting Firefox from console and trying to play flash movies with audio.
"(_snd_pcm_hw_open) Invalid value for card"

Expected results:
Sound playback

Additional info:
I've compiled this driver and it has worked just fine on previous kernels. Right now it's working on:
2.6.27.12-170.2.5.fc10.x86_64
after rebooting and choosing to go back to that kernel.
Just to be safe I had tried recompiling the Creative driver to see if that would fix the problem (no change) (FYI I did not recompile once I booted back to the older kernel and it works great everywhere). All my packages should be up to date as of today.

All other apps other than firefox from vlc, xine, and mplayer appear work just fine with sound on the NEWER kernel. Only flash appears to have a problem (in Konqueror as well).

firefox-3.0.6-1.fc10.x86_64
libflashsupport-000-0.5.svn20070904.x86_64
flash-plugin-10.0.22.87-release.i386
libflashsupport-000-0.5.svn20070904.i386

I know you guys might not care a whole lot about the XFi driver, but I was hoping there was some easy way to fix this. It appears the Creative Driver might need a simple patch perhaps or could this be a kernel bug?

SELinux is disabled if that matters at all.

I'm going to try to boot back into the new kernel and add more detailed info.
I believe you can download the source from:
http://support.creative.com/downloads/download.aspx?nDownloadId=10792
Comment 1 Matthew 2009-02-27 13:46:37 EST
Ok, booted back into newer kernel and sound breaks in Firefox only again.

Exact message from firefox is:
ALSA lib pcm.c:2162:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
LoadPlugin: failed to initialize shared library /home/mateo/.mozilla/plugins/libflashplayer.so [/home/mateo/.mozilla/plugins/libflashplayer.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /home/mateo/.mozilla/plugins/nprhapengine.so [/home/mateo/.mozilla/plugins/nprhapengine.so: wrong ELF class: ELFCLASS32]
Comment 2 Matthew 2009-03-09 14:05:40 EDT
Now of course I'm having trouble reproducing this.
Possibly after a new version of firefox, but not a new kernel, AND after a recompile of the Creative XFi Driver 1.00 Flash + Firefox + video/sound is working again.

Sigh. So I'm going to mark this as WORKSFORME since I can't seem to figure out what the heck happened here.

Note You need to log in before you can comment on or make changes to this bug.