Bug 487491 - RFE: support for sudo-style authentication
RFE: support for sudo-style authentication
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 04:21 EST by Robert Schuster
Modified: 2009-04-01 04:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 04:04:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Schuster 2009-02-26 04:21:13 EST
Description of problem:
This 'bug' is actually a request for enhancement (this cannot be chosen in the 'severity' box) and is set the component to system-config-soundcard because that is one of the apps that is affected by the enhancement although all system-config-* apps show the behavior.

What I ask for is a possibility to define users with administration rights. When I want to use a dialog like system-config-soundcard I should be able to authenticate for system-wide changes by typing in my users' password instead of that of the root user.

In distributions that use gksu there is a possibility to let it behave like gksudo by setting a gconf key. Basically this is the feature I am explaining here. However Fedora isn't using gksudo for the system-config-* apps.

Version-Release number of selected component (if applicable):
n/a

Steps to Reproduce:
1. Start one of the system-config-* apps.
  
Actual results:
System requests root user's password.

Expected results:
System should ask for user's password if configured so (e.g. through gconf or config file setting).

Additional info:
I hope this feature isn't already present somewhere. I asked for this in some forums already but either my problem was misunderstood or nobody knew an answer.

I also have no idea how dialog authentication works in fedora. I am willing to look into this issue myself if you could give me some pointers.
Comment 1 Martin Stransky 2009-03-25 09:39:20 EDT
Unfortunately system-config-soundcard has been removed from fedora times ago. Please post your request to fedora-devel list or choose another component for your RFE.
Comment 2 Martin Stransky 2009-04-01 04:04:55 EDT
Closing as CANTFIX. Please consider the possibilities from #1

Note You need to log in before you can comment on or make changes to this bug.