Bug 4875 - SW RAID autodetect fails -- md is module in default kernels
SW RAID autodetect fails -- md is module in default kernels
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-02 22:37 EDT by michaeloqu
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-03 10:18:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michaeloqu 1999-09-02 22:37:13 EDT
Actually autodetect works, it's "do_md_run()" that finally
fails.

I have created the arrays with persistent superblocks,
changed the partition type to 0xfd, and read all the bugs I
could find on bugzilla relating to this.

Everything works fine when booting, with autodetection
saying All The Right Things, right up until...

request_module[md-personality-4]: Root fs not mounted
do_md_run() returned -22
unbind<hdd1,3>
export_rdev(hdd1)
unbind<hdc1,2>
export_rdev(hdc1)
unbind<hdb5,1>
export_rdev(hdb5)
unbind<hda1,0>
export_rdev(hda1)
md4 stopped.
... autorun DONE.

It appears that md is compiled as a module in stock RH
kernels, but for autodetect to work, it needs to be _in_
the kernel.  (Notting@redhat.com has flatly stated in
comments in other bugs that autorun is the only form of
RAID RH supports under the current raidtools.)

This can be remedied by compiling and installing the a
correctly configured kernel, or perhaps by delving into
mkinitrd.

A more kludgey option is adding raidstart code to
rc.sysinit.  For everything to work properly, it has to go
after modprobe, but before fsck of the non-root
filesystems.  This will not work for RAID on root.

Also see related bug (don't have a number yet, since I
haven't yet entered it into the system) relating to doing
Software RAID installs.
Comment 1 michaeloqu 1999-09-02 23:02:59 EDT
The "other" bug is 4876, "Can't install RHL 6.0 onto SW RAID."
Comment 2 Bill Nottingham 1999-09-03 10:18:59 EDT
This is fixed in the latest mkinitrd in Raw Hide ; it adds
the md-personality-* modules to the initrd.

Note You need to log in before you can comment on or make changes to this bug.