Bug 48750 - kdesktop dumps core on logout (sometimes)
kdesktop dumps core on logout (sometimes)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
: 51430 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-11 09:47 EDT by Carlos Rodrigues
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-06 22:25:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2001-07-11 09:47:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
When logging off from KDE sometimes I get a coredump which gdb says 
belongs to "kdeinit: kdesktop". It happens randomly and I haven't figured 
out the cause.

How reproducible:
Sometimes

Steps to Reproduce:
1. start kde
2. use it for some time
3. log off
	

Actual Results:  Sometimes I get a coredump from kdeinit: kdesktop at the 
time of logoff.

Expected Results:  It shouldn't dump core.

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-07-16 09:26:00 EDT
Can't reproduce this; please attach a backtrace.
Comment 2 Alexei Podtelezhnikov 2001-07-16 12:52:12 EDT
Same here. I find coredumps once in a while.
Comment 3 Bernhard Rosenkraenzer 2001-08-10 10:08:16 EDT
*** Bug 51430 has been marked as a duplicate of this bug. ***
Comment 4 Tim Waugh 2001-08-10 10:10:03 EDT
I have a core file: see core-48750 in my home directory.
Comment 5 Steve Bonds 2001-10-29 11:45:49 EST
I'm having a similar problem with kdeinit, except it segfaults during normal
operations (usually slider moves or window moves), which locks up KDE entirely. 
(ctl-alt-backspace does not kill the window manager, so a reboot is required.)

I already tried rebuilding kdebase from the source RPM on my host, but the
problem persists.

The stack trace from the last crash:

Core was generated by `kdeinit: kdesktop'.
Program terminated with signal 11, Segmentation fault.
(gdb) bt
#0  chunk_free (ar_ptr=0x40d7fa00, p=0x80799a8) at malloc.c:3180
#1  0x40ccbcd4 in __libc_free (mem=0x80799b0) at malloc.c:3154
#2  0x40c09236 in __builtin_delete (ptr=0x80799b0)
   from /usr/lib/libstdc++-libc6.2-2.so.3
#3  0x4077675d in QObject::~QObject () from /usr/lib/qt-2.3.0/lib/libqt.so.2
#4  0x4053799e in KInstance::~KInstance () at eval.c:41
#5  0x404d2e05 in KApplication::~KApplication () at eval.c:41
#6  0x40566f99 in KUniqueApplication::~KUniqueApplication () at eval.c:41
#7  0x4116ce62 in main () from /usr/lib/kdesktop.so
#8  0x0804a49b in strcpy ()
#9  0x0804add1 in strcpy ()
#10 0x0804b2a6 in strcpy ()
#11 0x0804bff1 in strcpy ()
#12 0x40c67627 in __libc_start_main (main=0x804bc20 <strcpy+7972>, argc=2, 
    ubp_av=0xbffffb34, init=0x8049764 <_init>, fini=0x804c460 <_fini>, 
    rtld_fini=0x4000dcd4 <_dl_fini>, stack_end=0xbffffb2c)
    at ../sysdeps/generic/libc-start.c:129

<sarcasm>I know, memory allocation problems with Qt.  Shocking!</sarcasm>
Comment 6 Carlos Rodrigues 2001-12-21 16:47:45 EST
Since "no core files" is now the default and kdeinit does not give a 
"Segmentation fault" message I was fooled into thinking it was fixed, but no, 
it happens in Red Hat 7.2, but now it happens after _every_ logout from KDE.

Note You need to log in before you can comment on or make changes to this bug.