Bug 487503 - anaconda in F10 & F11 gets ok the kickstart network config, but stops and asks anyway
anaconda in F10 & F11 gets ok the kickstart network config, but stops and ask...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 06:40 EST by Pablo
Modified: 2010-02-17 14:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 14:47:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pablo 2009-02-26 06:40:17 EST
Description of problem:

Even if network parameters (dhcp) is specified in the kickstart file, the automated installation stops and asks for the network parameters.

I tried to set something like ip=10.11.12.13 and it is correctly shown, meaning that it is taken into account, but the installer stops anyway in the network configuration screen.

I tried with and without autostep.
I tried with and without ksdevice as linux kernel parameter.

The kickstart file specifies ks=floppy:/ks.cfg and the floppy ks.cfg specifies a repository in an ftp server.

The same kickstart file works fine in F9, meaning that it takes the network parameter (dhcp) and goes all the way through installation without stopping in the network screen.

The idea of this automatic installation is to install virtual machines, and user intervention is not permitted during installation.

Version-Release number of selected component (if applicable):

The version of fedora is 10. The version of anaconda is the anaconda that comes with the install DVD, which I think it is 11.4.1.62 or .63, I am not sure.

How reproducible:

Easy to reproduce. Here I put the ks.cfg file I am using:

install
url --url ftp://172.16.120.1/root/vm/tmp/image
lang en_US
keyboard us

network --device eth0 --onboot yes --bootproto dhcp --hostname caca
#with or without autostep doesn't make any difference
autostep
rootpw welcome
firewall --disabled
authconfig --enableshadow --enablemd5
selinux --disabled
timezone Europe/Paris
bootloader --location=mbr --append="rhgb quiet"
zerombr
clearpart --all --initlabel
part / --fstype ext3 --size=10 --grow
part swap --size=512
poweroff
%packages --nobase --ignoremissing 
*
%end


Steps to Reproduce:
1. just create a floppy with a similar ks.cfg with a proper ftp repository. 
2. boot an f10 cd or dvd (like netinst cd)
3. ....and before booting, add ks=floppy:/ks.cfg
  
Actual results:

Installs takes in account everything, even network, but instead of skipping the network config screen, it stops.

Expected results:

I am expecting not to stop during the entire installation, which is what happens with this same ks.cfg file using Fedora 9.

Additional info:
Comment 1 Chris Lumens 2009-02-26 11:02:05 EST
Is this still a problem in rawhide?
Comment 2 Pablo 2009-02-26 11:10:29 EST
(In reply to comment #1)
> Is this still a problem in rawhide?

Yes it is still there......at least when you arrive to that screen....which is not always the case due to some randoms SIGABRT that happen before that step.
Comment 4 Pablo 2009-09-09 08:24:26 EDT
I've just tried those modifications on the original stage2.img from the fc10 DVD, mounting it, patching it. remaking it with mkfs.cramfs, and putting it back into the DVD, and the bug is still present. The installer still stops in the network configuration screen (the installation in graphical mode as well as the text mode).
The machine has one network card, which is listed, and has the "[ ]" to select it, but it is not selected ([*]). And installation stops there waiting for user input.
ks.cfg file is correct.
Comment 5 Radek Vykydal 2009-09-22 04:26:51 EDT
This should be fixed in version 12.28 of anaconda.

Pablo, thanks for the report, in the end I used another patch (commit fe1208d5de4f2532180b6fb21a2605118a297840) which I have tested to work with rawhide, but I doubt it would work with fc10.
Comment 6 Pablo 2009-10-22 11:18:50 EDT
The problem is still present. And not only that...I discovered it is present also in Fedora 11 as well.
This is a major problem, as it blocks automatic installation without any workaround possible.
I am surprised that looking at the date of the creation of the bug, end February 2009, it is even in FC11. We'll see if FC12 carries also the issue. I am wondering which Fedora version could I expect to have a fix. Otherwise it would be a shame that I would have to change distro in order to have an automatic installation.

I am willing to test any potential solution, as I already did with the two patches from comment #3
I am willing to help developing the fix.

Please I need help here!!!
Comment 7 Bug Zapper 2009-11-16 04:49:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Pablo 2009-11-20 08:42:44 EST
Hi,

I just wanted to know if there is any hope to have a fix for this, fc10 or fc11 or fc12 or potentially fc13?

Thanks
Comment 9 Radek Vykydal 2009-11-20 09:00:25 EST
(In reply to comment #8)
> Hi,
> 
> I just wanted to know if there is any hope to have a fix for this, fc10 or fc11
> or fc12 or potentially fc13?

It should be fixed in F12.
Comment 10 Pablo 2009-11-20 09:12:01 EST
Yes. Just tested it.

Any way to fix the installer of fc11 or fc10 by backporting some code?

Note You need to log in before you can comment on or make changes to this bug.