Bug 487519 - Unable to run low-latency jobs needing access to files only available to owner
Unable to run low-latency jobs needing access to files only available to owner
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: grid (Show other bugs)
1.1
All Linux
urgent Severity urgent
: 1.1.1
: ---
Assigned To: Robert Rati
Jan Sarenik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 09:44 EST by Robert Rati
Modified: 2009-04-21 12:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 12:17:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2009-02-26 09:44:36 EST
Description of problem:
When running condor as the root user, I'm unable to run a job through the job hooks that is owned by a user.  Using a fetch hook of:

#!/bin/sh
echo 'Cmd = "/bin/date"'
echo 'Out = "/home/rrati/date.output"'
echo 'Err = "/home/rrati/date.err"'
echo 'Iwd = "/home/rrati"'
echo 'Owner = "rrati"'
echo 'JobUniverse = 5'


The starter complains of being unable to access the out/err files.  /home/rrati has perms of 700.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Rati 2009-02-27 09:15:17 EST
This was fixed in 7.1.2 upstream but apparently not merged to mainline, causing it to be broken in all releases since 7.1.2.  The above fetch hook script should now work correctly.

Fixed in:
condor-7.2.2-0.6
Comment 3 Jan Sarenik 2009-04-07 07:53:01 EDT
Bug reproduced on condor-7.2.2-0.4.el5

Verified on latest candidate condor-7.2.2-0.9,
both RHELs, both archs.
Comment 5 errata-xmlrpc 2009-04-21 12:17:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0434.html

Note You need to log in before you can comment on or make changes to this bug.