Bug 487551 - LiveCD should install i586 kernel, not PAE
LiveCD should install i586 kernel, not PAE
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 12:20 EST by Warren Togami
Modified: 2009-03-03 18:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 18:42:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-02-26 12:20:58 EST
https://fedoraproject.org/wiki/Features/ArchitectureSupport
After Fedora 11 switched to the new architecture plan for x86_32, the kernel became either i586 or i686 + PAE.

LiveCD created on a system with PAE support installs the i686 PAE kernel.  This means the LiveCD image will fail to boot on a x86_32 system without PAE.  Shouldn't the LiveCD explicitly install the i586 kernel instead?

livecd-tools-021-1.fc11
Comment 1 Jeremy Katz 2009-02-26 13:54:26 EST
There's nothing I see in either the configs or the code that would be selecting kernel-PAE and with the build I just did, kernel.i586 got pulled in.

Do you have any out of the ordinary yum plugins installed or something?
Comment 2 Jeremy Katz 2009-03-03 18:42:52 EST
I can't reproduce this at all with current livecd-tools and repos.  If you're still hitting it, please attach a log of your build and the output of 'rpm -qa yum*' from your build host.

Note You need to log in before you can comment on or make changes to this bug.