Bug 487557 - libvirtd forgets about migrated guests when it is restarted
libvirtd forgets about migrated guests when it is restarted
Status: CLOSED NEXTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 12:52 EST by Chris Lalancette
Modified: 2010-03-16 13:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-30 07:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2009-02-26 12:52:11 EST
Description of problem:

There's a corner case with the new libvirtd feature to "remember" guests when it is restarted.  Take the following example:

1.  virDomainDefineXML on src
2.  virDomainStart on src
3.  virDomainMigrate on src -> migrates guest to dest
4.  Shut-down libvirtd on dest
5.  Restart libvirtd on dest

After step 5, you would expect libvirtd to "remember" the migrated guest, but at present, it does not.  DanB says this is because it is a "transient" guest, so doesn't have an /etc/libvirt/qemu config file.  It does, however, have a /var/run/libvirt/qemu state and pid file, so we could scan the entire directory looking for transient guests as well.
Comment 1 Daniel Berrange 2009-05-27 12:00:47 EDT
Prototype fix posted

http://www.redhat.com/archives/libvir-list/2009-May/msg00573.html
Comment 2 Gerrit Slomma 2009-07-29 17:01:01 EDT
This problem still exists in libvirt-0.6.3-11.el5.x86_64.rpm from rhel5.4 beta.
Is there a plan to integrate the fix into the release?
Comment 3 Daniel Berrange 2009-07-30 07:40:15 EDT
The redetection of transient VMs is now fixed in libvirt repos. The fix will be included in the forthcoming 0.7.0 release

http://libvirt.org/git/?p=libvirt.git;a=commit;h=56a46886ad4335b81daac32c86c77ccbcefa3e23

Note You need to log in before you can comment on or make changes to this bug.