Bug 487615 - Please upgrade to emacs-23.1 for F11 or F12 if too late for F11
Please upgrade to emacs-23.1 for F11 or F12 if too late for F11
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
11
All Linux
low Severity urgent
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 19:48 EST by dann
Modified: 2009-08-11 18:36 EDT (History)
7 users (show)

See Also:
Fixed In Version: 23.1-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-11 18:36:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against Fedora CVS for Emacs 23.0.91 (11.16 KB, patch)
2009-03-03 23:24 EST, Debarshi Ray
no flags Details | Diff

  None (edit)
Description dann 2009-02-26 19:48:50 EST
emacs-23 is already in pretesting.
It would be great if F11 would ship with emacs-23 instead of emacs-22.

The number of new features is huge, and nothing can replace being able to use
antialiased fonts or to have the same emacs session use both X11 and tty frames.
Comment 1 Debarshi Ray 2009-02-26 23:44:52 EST
I have been using Emacs 23.0.90 on a Fedora 9 and a very old Fedora Core 5 system for sometime, and I have encoutered the odd crash mostly on the Fedora Core 5 system. My fault for not reporting them upstream.

Looks like Emacs 23.0.91 is now available. Will give it a try now.
Comment 2 Jonathan Underwood 2009-02-27 06:54:04 EST
My feeling is that it is too late for F-11. I have been following the development list, and trying the pretests, and my feeling is that it's still too buggy to replace Emacs 22 in F-11. Had the pretest started earlier in the F-11 cycle it might have been possible, but this close to the feature freeze, and with problems still evident in the pretest, I think it's better to wait until F-12 for Emacs 23. Perhaps the other package maintainers have different thoughts on this though.
Comment 3 dann 2009-02-27 12:57:11 EST
(In reply to comment #2)
> My feeling is that it is too late for F-11. I have been following the
> development list, and trying the pretests, and my feeling is that it's still
> too buggy to replace Emacs 22 in F-11. Had the pretest started earlier in the
> F-11 cycle it might have been possible, but this close to the feature freeze,
> and with problems still evident in the pretest, I think it's better to wait
> until F-12 for Emacs 23. Perhaps the other package maintainers have different
> thoughts on this though.

As someone that fixes bugs in emacs, I think it's in a good shape.
There has been a lot of work lately on fixing RMAIL, which has just been rewritten before the pretest. RMAIL is not by the vast majority of users.
A lot of the bug fixes are for problems that exist in older versions of emacs.
IMVHO the risk/reward ratio is pretty good.
Comment 4 Daniel Novotny 2009-03-03 07:20:39 EST
it's still pre-release, isn't it? how long do you think will it take to final release of 23?
Comment 5 dann 2009-03-03 13:32:06 EST
(In reply to comment #4)
> it's still pre-release, isn't it? how long do you think will it take to final
> release of 23?

Unfortunately nobody is going to be able to answer that question...
Comment 6 Debarshi Ray 2009-03-03 23:24:17 EST
Created attachment 333972 [details]
Patch against Fedora CVS for Emacs 23.0.91

I just rebased my personal emacs-23.0.90 package with Fedora's Rawhide, updated it to Emacs-23.0.91 and submitted a Koji scratch build.

Will let you know how things progress.
Comment 7 Debarshi Ray 2009-03-03 23:25:19 EST
(In reply to comment #4)

> it's still pre-release, isn't it? how long do you think will it take to final
> release of 23?

Maybe we can target Fedora 12 and later updates to Fedora 11 and Fedora 10.
Comment 8 Debarshi Ray 2009-03-04 00:05:54 EST
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=1219191
Comment 9 Jonathan Underwood 2009-03-04 08:22:04 EST
(In reply to comment #7)
> (In reply to comment #4)
> 
> > it's still pre-release, isn't it? how long do you think will it take to final
> > release of 23?
> 
> Maybe we can target Fedora 12 and later updates to Fedora 11 and Fedora 10.

This approach gets my vote - we can drop an emacs 23 package into updates testing for F11 pretty quickly after F11 release - it needs a good testing before being part of F11.
Comment 10 Filippo Argiolas 2009-03-08 04:48:34 EDT
Probably I'm a bit late for this suggestion, but did you consider following the same path Ubuntu did? They provided two emacs packages (not sure what they'll do now that emacs 23 is in pre-testing): a normal emacs package like the one provided by fedora and an emacs-snapshot (IIRC, I could be wrong about the name) to test exciting new features like unicode and xft support from the development branch.
This way the default is still the stable version but there is a chance to install the testing version on purpose.
Comment 11 Debarshi Ray 2009-03-10 01:10:04 EDT
Apparently Emacs 23.0.91 solves this: https://bugzilla.redhat.com/487757
Comment 12 Daniel Novotny 2009-05-15 07:02:43 EDT
hello,
Maybe I will upgrade to 23.0.93 in rawhide...
I have made a scratch build, so take a look, if there are any problems... if not, I will probably do the upgrade on Monday

http://koji.fedoraproject.org/koji/taskinfo?taskID=1355827
.spec is here: http://people.fedoraproject.org/~dnovotny/emacs/emacs23.spec
Comment 13 Filippo Argiolas 2009-05-17 04:42:29 EDT
(In reply to comment #12)
> hello,
> Maybe I will upgrade to 23.0.93 in rawhide...
> I have made a scratch build, so take a look, if there are any problems...

Seems to work pretty fine here, no issues after a couple of days using it.
Will we have this in fedora 11 too?
Comment 14 Daniel Novotny 2009-05-18 07:39:57 EDT
so rawhide (F12) is updated to 23.0.93 now,

F11 is in development freeze now, I will target later updates, if the rawhide version won't show any serious problems
Comment 15 Bug Zapper 2009-06-09 07:41:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 dann 2009-07-29 23:36:56 EDT
emacs-23.1 has been released.
Comment 17 Amadeus 2009-08-01 15:59:01 EDT
The reporter have to change this to Fedora 12.

http://fedoraproject.org/wiki/Releases/12/Schedule

Or that might be F13 now =(
Comment 18 Amadeus 2009-08-01 16:39:13 EDT
You can close the bug.

23.1 have been added to rawhide 2 days ago for F12.

http://ftp.crc.dk/fedora/linux/development/i386/os/Packages/
Comment 19 Daniel Novotny 2009-08-03 05:48:46 EDT
I will also upgrade it for F11, because it can fix a few issues there
Comment 20 Fedora Update System 2009-08-03 05:51:14 EDT
emacs-23.1-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/emacs-23.1-1.fc11
Comment 21 Fedora Update System 2009-08-03 15:24:32 EDT
emacs-23.1-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update emacs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8245
Comment 22 Fedora Update System 2009-08-11 18:36:15 EDT
emacs-23.1-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.