Bug 487624 - kdesdk-util po tools don't handle blockquote correctly
kdesdk-util po tools don't handle blockquote correctly
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdesdk (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 00:13 EST by Jeff Fearn
Modified: 2009-05-29 22:39 EDT (History)
8 users (show)

See Also:
Fixed In Version: 4.2.3-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 22:28:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2009-02-27 00:13:04 EST
Description of problem:
The po tools do not understand blockquote and generate pot files that are very hard to translate.

Version-Release number of selected component (if applicable):
kdesdk-utils-4.2.0-2

How reproducible:
Any time you use blockquote in a docbook file.

Steps to Reproduce:
1. Add a blockquote to your docbook.
2. update your pot file
  
Actual results:
All content inside the blockquote, and after content the blockquote until the end of the block containing the blockquote, is contained in a single msgid in the pot file.

Expected results:
Block level tags, such as para and lists should be in separate entries.

Additional info:
This appears to be due to a misspelling of blockquote as blockingquote in parser.cpp

Correct tag name: http://www.docbook.org/tdg/en/html/blockquote.html

Offending pot file: http://svn.fedorahosted.org/svn/publican/trunk/publican/content/common/pot/Conventions.pot

Offending xml file: http://svn.fedorahosted.org/svn/publican/trunk/publican/content/common/en-US/Conventions.xml
Comment 1 Rex Dieter 2009-02-27 08:48:03 EST
I'd recommend reporting upstream to bugs.kde.org.  We most likely don't have the expertise (or time honestly) to investigate/fix this ourselves (in feodra) for the foreseable future.
Comment 2 Kevin Kofler 2009-02-27 12:17:15 EST
If this is really just a s/blockingquote/blockquote/g, we should be able to do it (and also commit the fix upstream).
Comment 3 Rex Dieter 2009-02-27 12:21:56 EST
Oh, my bad for not noticing the potential "easyfix" here.
Comment 4 Rex Dieter 2009-02-27 12:41:47 EST
I'll work on this.
Comment 5 Rex Dieter 2009-02-27 12:50:34 EST
patch should land in kdesdk-4.2.1-1
Comment 6 Steven M. Parrish 2009-04-04 18:11:25 EDT
Did this make it into 4.2.1-1?
Comment 7 Rex Dieter 2009-04-04 19:34:55 EDT
yes, included in kdesdk-4.2.1-1 and newer
Comment 8 Ruediger Landmann 2009-05-27 20:11:40 EDT
The patch seems to be missing from kdesdk-4.2.3-1, and the bug has returned.
Comment 9 Rex Dieter 2009-05-27 20:35:29 EDT
Looks like the patch indeed got dropped in the 4.2.3-1 build, we should be able to get this back in asap. (And I'll be sure to upstream the fix this time).
Comment 10 Fedora Update System 2009-05-28 13:11:45 EDT
kdesdk-4.2.3-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kdesdk-4.2.3-2.fc11
Comment 11 Fedora Update System 2009-05-28 13:12:35 EDT
kdesdk-4.2.3-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kdesdk-4.2.3-2.fc10
Comment 12 Fedora Update System 2009-05-28 13:13:15 EDT
kdesdk-4.2.3-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kdesdk-4.2.3-2.fc9
Comment 13 Fedora Update System 2009-05-29 22:28:36 EDT
kdesdk-4.2.3-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-05-29 22:32:37 EDT
kdesdk-4.2.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-05-29 22:38:58 EDT
kdesdk-4.2.3-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.