Bug 487723 - phpmyadmin dependency with httpd
phpmyadmin dependency with httpd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: phpMyAdmin (Show other bugs)
10
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 11:52 EST by Arnaud WOROBEL
Modified: 2009-02-27 12:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 12:13:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnaud WOROBEL 2009-02-27 11:52:55 EST
Description of problem:
Hello. Although a config file for httpd is provided with package, i think it is not correct to make a dependancy with httpd.
Indeed if users plan to use another web server like lighttpd, it is problematic for file's rights.

Currently the "solution" is to add lighttpd in apache group but it is not clean at all :/


Version-Release number of selected component (if applicable):
3.1.2-1.fc10

How reproducible:
Simply do a yum install phpmyadmin to see the dependancies :)

Steps to Reproduce:
1.
2.
3.
  
Actual results:
phpmyadmin package installs httpd as a dependencie

Expected results:
Package phpmyadmin not dependent of httpd

Additional info:
Comment 1 Robert Scheck 2009-02-27 12:12:05 EST
"Requires: webserver" is the only requirement which can cause this. Yum
prefers httpd over lighttpd (both provide webserver), as "h" is before "l"
in the alphabet. Thus this not a bug of phpMyAdmin.

Note You need to log in before you can comment on or make changes to this bug.