Bug 48773 - Not enough memory to install Red Hat on this machine during install
Not enough memory to install Red Hat on this machine during install
Status: CLOSED DUPLICATE of bug 36940
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-11 13:04 EDT by dshapin
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dshapin 2001-07-11 13:04:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win95; U)

Description of problem:
Redhat 7.1 Anaconda does not load the install program on a Compaq Proliant 1500 with 128MB and an integrated
wide fast scsi-2/p controller. I can install Red Hat 5.2 on this computer from the CD, but the 7.1 install does not work.

How reproducible:
Always

Steps to Reproduce:
1.Boot 
2.Loads image files
3.Then Anacondo tried to start the install and an errorr occurs - not enough memory to install on Red Hat on this machine.
	

Actual Results:  The Install process aborts and the machine reboots.

Expected Results:  The install process to load and continue.

Additional info:

I opened a support call with Red Hat and they said there are known problems with 7.1 and scsi controllers.
Comment 1 Matt Wilson 2001-07-12 10:46:01 EDT
Boot the machine with:

"linux mem=exactmap mem=128M@0"
Comment 2 Arjan van de Ven 2001-07-12 10:55:21 EDT
"linux mem=exactmap mem=640k@0 mem=128M@1M"
rather
Comment 3 dshapin 2001-07-12 14:28:28 EDT
The install process went further with the "linux mem=exactmap mem=128M0" however I got the error message

python: header.c:511 headerLoad: Assertion 'rdlen == dl' failed install exited abnormally -- recieved signal 6 sending termination 
signals...done sending kill signals...done disabling swap... /tmp/swap/sda7 unmounting filesystems...<F1> for help|/mnt/sysimage/bootments
| <<<Space> select | <F12> next screen /mnt/sysiamge/home /mnt/sysimage/rpoc /mnt/sysimage/var /mnt/sysimage/use /mnt/sysimage
/mnt/runtime /mnt/source umount failed () /dev/pts /proc you may safely reboot your system.

CTL-DEL-F4 screen last line displays

<6>Adding Swap: 265032k swap-space (priority -)

CTL-DEL-F3 screen last linees display

* Detected 128M of memory
* Swap attempt of 128M to 256M
* Maximum cylinder is 7

It appears the swap space was not created properly on the drives.

Comment 4 dshapin 2001-07-12 16:17:00 EDT
Removed two of the three Compaq Hot pluggable 4.2 GB drives to see if maybe the drive array was causing a problem. 

When I booted with one hard drive it got as far as copying the image to the hard drive and then the kernal paniced.

pmd entry c7fc84a8: 00000000000000000000000
...pmd not present!
Oops: 0002
CPU: 0
EIP:  0010:[<c0126fff>]
EFLAGS: 00010087
eax: 4a9b3820 ebx: c00f2020 ecx: c0073000 ed c004a010
esi: c7ffdcdc edi: 00000202 ebp: 00000968 esp: c7ff1e54
ds: 0010 es: 0018 ss:0018
Process linuxrc (pid:8, stackpage=c7ff1000)
Stack: c0073a20 c0073a20 c0073a20 c0073a20 00000000 c01327a8 c7ffdcdc c0073a20
             00000003 0000000001 00000000 00000000 00000017 c0073a20 00001000 c0073a20
             00000000 c01310ba c10017f8 000000000 0000008f2 c10017f8 c100183c 00000000
Call Trace: [<c-1327a8>] ..... more numbers

Code: 89 08 eb 28 90 8b 46 08 8b 58 04 8b 51 04 8b 01 89 50 04 89
EXT2-fs: unable to read superblock
isofs_read_super: bread failed, dev=09:00, iso_blknum=16, block 32
FAT bread failed
FAT bread failed
Kernal Panic: VFS: Unable to mount root fs on 09:00

Looks like it is unable to mount the root. SCSI controller problem? The scsi controlle works fine with Red Hat 5.2.
Comment 5 Arjan van de Ven 2001-07-12 16:18:17 EDT
that is with 
"linux mem=exactmap mem=640k@0 mem=127M@1M"

??
Comment 6 dshapin 2001-07-12 17:38:01 EDT
I booted with linux mem=exactmap mem=640k@0 mem=128M@1M

Thanks that worked!
Comment 7 Arjan van de Ven 2001-07-12 17:46:49 EDT
Ehm I made a typo, it needs to be "127" not "128", eg 1 less than you have,
so it is 640Kb in "low memory" and an additional 127Mb in "high" memory.


Also, if you install the updated 2.4.3-12 kernel, you can use the old style
"mem=128M" again.

Comment 8 Panic 2001-08-14 16:41:54 EDT
This workaround is confirmed to work with at least one other machine, this time
a ProLiant 1500 with a SmartArray 221 (4 drives, RAID5).
Comment 9 Alan Cox 2003-06-06 10:35:29 EDT

*** This bug has been marked as a duplicate of 36940 ***
Comment 10 Red Hat Bugzilla 2006-02-21 13:48:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.