Bug 487739 - Unable to setup cloning
Unable to setup cloning
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: Cloning (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Ade Lee
Chandrasekar Kannan
:
: 481152 (view as bug list)
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-02-27 12:58 EST by Asha Akkiangady
Modified: 2015-01-05 20:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:32:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix (2.53 KB, patch)
2009-03-03 13:55 EST, Ade Lee
no flags Details | Diff

  None (edit)
Description Asha Akkiangady 2009-02-27 12:58:41 EST
Description of problem:
When cloning setup is executed through wizard getting error "Failed to setup the replication for cloning".

Version-Release number of selected component (if applicable):
8.0

How reproducible:
Always

Steps to Reproduce:
1.This bug is discovered during fix for https://bugzilla.redhat.com/show_bug.cgi?id=486191

richm suggestion : The code should wait a second or two (not sure exactly how long)
before attempting to search for the index task entry - since the add request
returned success, the entry should be there.  By default, task entries have a
TTL (time to live) of 120 seconds.  So even after the task is completed, the
entry should be there for at least 120 seconds.  The "ttl" attribute in the
task entry can be set to another value if desired.


  
Actual results:


Expected results:


Additional info:
Comment 1 Ade Lee 2009-03-03 13:55:27 EST
Created attachment 333913 [details]
patch to fix

So - there were several things wrong.

1. The value of the index in wait_dn in CS.cfg was wrong meaning that the test always failed.
2. The test was incorrect.  

As explained in : http://directory.fedoraproject.org/wiki/Task_Invocation_Via_LDAP, task completion is signaled by the presence of a specific attribute. (nsTaskExitCode).

The new check is written to ensure -- 
1. the task entry exists 
2. the task is complete (check status code)

We always expect to catch the task status because the task entry has a default TTL of 120 seconds.

In the past, the fact that this test was so broken did not matter because the indexes were the last thing to be created.  Index creation has recently moved to  being prior to creation of the replication agreements though (as it needs to be)- so now the test is important. 

awnuk, please review.
Comment 2 Ade Lee 2009-03-03 14:00:45 EST
*** Bug 481152 has been marked as a duplicate of this bug. ***
Comment 3 Andrew Wnuk 2009-03-03 17:33:36 EST
attachment (id=333913) +awnuk
Comment 4 Ade Lee 2009-03-04 00:43:58 EST
[builder@oliver pki]$ svn ci -m "Bugzilla Bug #487739 -  Unable to setup cloning" base
Sending        base/ca/shared/conf/CS.cfg
Sending        base/common/src/com/netscape/cms/servlet/csadmin/DatabasePanel.java
Transmitting file data ..
Committed revision 272.
[builder@oliver pki]$ svn ci -m "Bugzilla Bug #487739 -  Unable to setup cloning" dogtag
Sending        dogtag/ca/pki-ca.spec
Sending        dogtag/common/pki-common.spec
Transmitting file data ..
Committed revision 273.
Comment 5 Asha Akkiangady 2009-05-29 15:58:47 EDT
Verified that CA clone can be created. A separate bug filed for the database panel spinning during configuration bz https://bugzilla.redhat.com/show_bug.cgi?id=502240 .

Note You need to log in before you can comment on or make changes to this bug.